WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 06-27-2003, 10:43 AM
FlyingWren FlyingWren is offline
Member
 
Join Date: Mar 2003
Location: Fargo, North Dakota, USA
Posts: 48
.max ---> .vrml

We model our geometry in 3DS Max 5.0 and export to VRML.

However, the VRML objects end up being about a hundred times bigger - i.e., what is modeled as being 1 meter tall in Max ends up as 100-something meters from with Vizard.

Obviously, there's some sort of disparity in the coordinates -- while we could shrink everything we make before presenting it in Vizard, it would be nice if we could achieve a WYSIWYG (what-you-see-is-what-you-get) relationship.

Anyone else know of a workaround?
Reply With Quote
  #2  
Old 06-27-2003, 12:38 PM
farshizzo farshizzo is offline
WorldViz Team Member
 
Join Date: Mar 2003
Posts: 2,849
Hi,

I think you might have the wrong unit scale set in 3DS Max. Go to the preferences and make sure 1 Unit = 1 Meter. Try creating a simple box and set its length,width, and height to 1. I just tried that using 3DS Max 4 and it works fine.

-- Farshid
Reply With Quote
  #3  
Old 06-27-2003, 02:06 PM
FlyingWren FlyingWren is offline
Member
 
Join Date: Mar 2003
Location: Fargo, North Dakota, USA
Posts: 48
OK, I made a cube.

I set its parameters to 1 meter in all dimensions. I double-checked our unit and grid settings (they are indeed in meters), and also measured the size of the box from within MAX in various other ways (don't ask - heh).

I did a File --> Export ---> VRML97, and leave all of the default settings in the dialog box that comes up.

When I load this object from within Vizard, I get the "it's way too big" problem again.

Really, this isn't surprising, because if you look at the .VRML file in a text editor, the coordinates listed are all way bigger than 1.0 (indeed, the box is mysteriously specified as exactly 39.37 meters in all three dimensions). This is about the scale we see it as when we get the "it's way too big" effect.

I'm wondering if it's something funky in Max 5's VRML conversion.

If you take the BLUECUBE.MAX file (attached) and export it to vrml from 3ds Max 4, is your resulting file the same as BLUECUBE.VRML (also attached)?

(I hate to ask you to do this, but it might help dissociate where the problem lies.)
Attached Files
File Type: zip bluecube.zip (8.5 KB, 630 views)
Reply With Quote
  #4  
Old 06-27-2003, 02:22 PM
FlyingWren FlyingWren is offline
Member
 
Join Date: Mar 2003
Location: Fargo, North Dakota, USA
Posts: 48
Oops. In the journey to detailing my problem, I figured it out. (Thanks for your helpfulness, though, farshid-- !)

Reading my own post, I realized that the myterious number of the cube (39.37) is special in that it is the number of inches in a meter.

Changing the cube from 1-m square to 1-inch square makes it show up as 1-m square in both the VRML and Vizard.


The bottom line:
---------------
Seems like there is a bug in Max 5.

If using 3ds Max 5, make sure the default unit in the program is set up as inches.

Treat this word "inches" as if it said "meters," and model your geometry as such.
Reply With Quote
  #5  
Old 07-08-2003, 12:31 PM
tobin tobin is offline
WorldViz Team Member
 
Join Date: Feb 2003
Posts: 251
Units settings in Max3/4/5

The recommended solution is to simply set your units (under the customize menu) to "generic". This prevents Max from ever trying to perform unit conversion. Its internal units appear to be inches, as you discovered, and I believe this is for historical reasons owing from its relationship to a predecessor product, Autocad.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC