WorldViz User Forum

WorldViz User Forum (https://forum.worldviz.com/index.php)
-   Vizard (https://forum.worldviz.com/forumdisplay.php?f=17)
-   -   eMagin disconnecting after time has passed/after a sound has played (https://forum.worldviz.com/showthread.php?t=1933)

Enlil 03-25-2009 02:55 PM

eMagin disconnecting after time has passed/after a sound has played
 
Hello,

I am having a bit of a problem with the orientation sensor in the eMagin VR glasses. At a somewhat random interval, I lose contact with the glasses. If I use vizact.speech actions, I can make it fail a lot faster. I tried .reset(), but that appears to set the current orientation to [0,0,0]. Is there a way using command() or some other function to disconnect and reconnect with the glasses?

Thanks,
Christian

Jeff 03-27-2009 02:03 PM

Is the Emagin utility program installed on your computer? That has been known to cause problems.

tobin 03-28-2009 09:28 PM

Is the HMD display remaining on or is it turning off too?

Enlil 04-01-2009 07:42 AM

The utility is still installed, but has been turned off - I will try uninstalling it completely and run more tests, and report the results.

The HMD still displays the scene, we just lose the tracking data. But we have never quite gotten the 3d working, so it is just a clone of the monitor.

Thanks,
Christian

Gladsomebeast 04-01-2009 08:26 PM

Maybe the eMagin connection is timing out?

Might try installing eMagin's Lab Tool available here:
http://www.3dvisor.com/support.php
and turn off or mazimize the timeout settings.

This tool is pritty handy for other emagin stuff. But don't think you can't run it while connected to the eMagin tracker with Vizard.

Then again, the drift on the eMagin tracker is so bad its really only useful for relative gesture recognition.


All times are GMT -7. The time now is 04:13 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC