PDA

View Full Version : 3D monitor display with Vizconnect


rdkirkden
09-13-2017, 05:21 AM
Please can somebody tell me how I can get a monitor display suitable for NVIDIA 3D Vision glasses when using Vizconnect? When not using Vizconnect, I just have to type ‘viz.go(viz.QUAD_BUFFER | viz.FULLSCREEN)’. I found some brief instructions in the Vizard Reference (http://docs.worldviz.com/vizard/#vizconnect_displays.htm%3FTocPath%3DReference%7CV izconnect%7CAdvanced%20GUI%7C_____3), but they don’t seem to work. Following these instructions, I chose ‘Custom Window’ for the Display. But regardless of whether I went with the default option of ‘stereo’ = viz.OFF, or changed this to ‘stereo’ = viz.QUAD_BUFFER, the result was an ordinary 2D display.

Is there another setting that I’m missing? The instructions begin by saying ‘Configure the graphics output for a 2D or 3D monitor setup’, but it is not clear whether this refers to a setting on my PC or in the Vizconnect Configuration Utility. As regards my PC, I don’t think I have to change anything because I’m already able to get a 3D view with Vizard when not using Vizconnect; and as regards the Configuration Utility I can’t find any such setting.

Thanks,
Richard

Jeff
09-14-2017, 01:25 AM
It sounds like you're setting it up correctly in vizconnect. The quad buffered stereo will not work immediately after you apply the setting in the vizconnect GUI. You must save the config file and then run it again because quad buffered stereo needs to be initialized before the graphics window opens. Does that work for you?

rdkirkden
09-14-2017, 03:17 AM
Hi Jeff,

Many thanks for your reply. Ensuring that the vizconnect_config file was saved and then re-running the Vizard program did not help. However, your observation that the quad buffered stereo needs to be initialised before the graphics window opens guided me to the relevant part of the vizconnect_config file code that I needed to change to get the 3D view working.

There are two lines of code in the vizconnect_config file’s ‘initDisplays’ procedure that deal with the quad buffer setting. One line (‘viz.setOption('viz.stereo', viz.QUAD_BUFFER)’) executes very early on, before viz.go; while the other (‘stereo = viz.QUAD_BUFFER’) sets a variable that is used a bit later, when the display is being created. I remembered that in a Vizard program I wrote for the 3D glasses that did not use Vizconnect, it was not sufficient to specify ‘viz.QUAD_BUFFER’ in the the viz.go command; rather I had to specify ‘viz.QUAD_BUFFER | viz.FULLSCREEN’ to get a 3D display. So I tried modifying the two lines of code in the vizconnect_config file to ‘viz.setOption('viz.stereo', viz.QUAD_BUFFER | viz.FULLSCREEN)’ and ‘stereo = viz.QUAD_BUFFER | viz.FULLSCREEN’, and this gave me a 3D display. Further trial and error showed that only the first line of code actually needed to be modified.

Best regards,
Richard.