PDA

View Full Version : Prevent Oculus DK2 updating the view with accelerometer info


Notch
10-24-2014, 11:53 AM
I am using an Oculus Rift DK2 in conjunction with a motion capture system. Mocap markers attached to the DK2 determine the position of the 'head' and therefore the viewpoint that comes through to the screen.

However, since upgrading to the DK2, I've noticed that, even if I *don't* want the accelerometers inside the DK2 to affect the view, every time I jolt the headset, the image inside the display 'stretches' from the edges to counteract the head motion. Presumably, this must be some new method of image stabilisation to reduce motion sickness, but in my application, since I rely on the position signal from the mocap cameras, having the screen warp like this actually *increases* motion sickness.

How do I prevent the Oculus Rift from stretching the edges of my screen like this? My code is identical for both DK1 and DK2 setups, so this is likely to be a feature within the DK2 itself, but I wonder if anyone else on here has come across this problem.

farshizzo
10-24-2014, 12:01 PM
I believe this is caused by the new timewarp feature of the Oculus SDK. You can disable it using the following code:
hmd.setTimeWarp(False)

Notch
10-24-2014, 12:04 PM
I've just realised that this issue also exists on the DK1 - it happens when the USB cable is plugged in only. I had only noticed it since upgrading to DK2 as the DK2 requires the USB cable plugged in to work.

Notch
10-24-2014, 12:06 PM
Perfect! Thanks Farshizzo. This has fixed the issue. Possibly another reason I thought it was only the DK2 is due to the fact that back in the days when I used to use the DK1 with the USB cable, the SDK didn't have this feature.

Thanks again.