View Full Version : The memory could not be "read" error when starting Vizard 4

04-30-2012, 06:20 PM

I'm having some issues after I updated Vizard 4 from Beta to the latest version. Earlier today I launched Vizard 4 on a seldom used computer, and was greeted with a "Your beta licence has expired, please register" screen. I registered with a development key and everything worked fine. I ran an update check, followed the link, downloaded the latest version, installed it and was preparing to get on with my work when this happened:

Event Type: Information
Event Source: Application Popup
Event Category: None
Event ID: 26
Date: 4/30/2012
Time: 4:31:54 PM
User: N/A
Computer: SR-01817
Application popup: Vizard 4.0 Development (32-bit): Vizard.exe -
Application Error : The instruction at "0x004092fc" referenced memory
at "0x00000004". The memory could not be "read".

Click on OK to terminate the program
Click on CANCEL to debug the program

This happens every time I try to launch Vizard 4. Vizard 3 works fine. Reinstalling Vizard 4 did nothing. Clicking Cancel to debug does nothing. I'm currently checking the RAM and drivers and such to rule that out, but I wanted to check here as well to make sure there isn't something weird going on with Vizard.

Is there a way to completely uninstall Vizard 4? When I reinstalled, it still said "Development" when I tried to run it, indicating that the licence information didn't get uninstalled. Is there a way to completely nuke the entire thing?

04-30-2012, 11:45 PM
Oh yeah, and the OS is Windows XP, latest service pack.

05-01-2012, 11:38 AM
After uninstalling Vizard 4, are there any files remaining in the installation folder (e.g. C:\Program Files\WorldViz\Vizard4)?

05-01-2012, 11:50 AM
Also, not sure this will help, but you can try deleting the Vizard 4 application data after uninstalling. For Windows XP, it should be located at C:\Documents and Settings\<username>\Application Data\WorldViz\Vizard4.

05-01-2012, 12:45 PM
I removed any leftovers in Program Files when I uninstalled before, but I haven't tried getting rid of the application data. Will try that after this extremely long chkdsk process finishes. Thanks.

05-01-2012, 05:23 PM
Nope, that didn't work. After completely removing any and every reference to Vizard 4 (using Revo Uninstaller), even a fresh evaluation download installed as Vizard 4 Development and gave the exact same error. Vizard 4 just won't run on this computer.

05-02-2012, 01:26 PM
Update: This was probably not Vizard's fault, as the same error started popping up elsewhere. Chalked it up to a corrupt registry and wiped the machine clean. Thanks for the help though.