PDA

View Full Version : VizUtils


kim_swinth
10-04-2004, 12:14 PM
Hi Farshid (and all)...

I am having a problem with the VizUtils module that I'm hoping you can help me with.

I've attached a sample script that I wrote for ATI called "Avatar_Inspection_Experiment" that uses VizUtils.

When the world loads, hit the "S" key to start the program.

You'll notice that an avatar appears with a Likert scale over his/her head and participants are asked to make a rating about the avatar.

The problem is, the numbers for the scale don't show up. It looks like a problem with z-buffering or something, but I've played around with the parameters in the VizUtils script quite a bit and can't seem to get the problem fixed. If I navigate around with my mouse, then I can see the numbers, but you shouldn't have to do that.

I'd like to use something similar on an experiment I'm running this quarter, but need to get the z-buffering (or whatever problem it is) fixed first.

Any ideas about what is wrong?

I'm also having problems with the "SaveData" function in VizUtils. I want to create a unique datafile for each participant (which I am able to do). But I can't get the program to NOT make a default file (which in this case is called "TrackingData"). The main problem is that the "TrackingData" file does not ever seem to get released unless I actually exit Vizard. Any idea why?

Thanks in advance for your help!

Kim

kim_swinth
10-04-2004, 12:34 PM
Hi,

You can disregard the first part of my last posting.

I finally got the scales to show up by changing one of the lines in the LikertScale Class of the VizUtils module to:

q.translate(0,.3,.1)

Before, I had been working with the following lines:

q.zoffset(40)
t.zoffset(30)

and that didn't do anything.

However, I still have problems with the SaveData function.

Sorry for wasting your time on the first part! I worked with that for several hours during ATI, but was clearly on the wrong track.

Kim