WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 07-13-2010, 01:42 PM
llqqff llqqff is offline
Member
 
Join Date: May 2009
Posts: 25
<vicon>.getBody() problem

Hi, I am using Vicon tracker with Vizard, there are three objects in vicon tracker, my code is as below:
vicon = viz.add('vicon.dle',0,'129.59.70.136')
marker = vicon.getMarker(0)
print marker.getName()
body = vicon.getBody(0)
print body.getName()

But it shows error:
File "<string>", line 11, in ?
File "test for getbody.py", line 24, in ?
body = vicon.getBody(0)
File "<string>", line 29, in getBody
KeyError: 0

Is anyone know what's the problem.

And when I use:
for b in vicon.getBodyList():
print b.getName()
there is nothing print out.
Thanks.
Reply With Quote
  #2  
Old 07-13-2010, 01:46 PM
farshizzo farshizzo is offline
WorldViz Team Member
 
Join Date: Mar 2003
Posts: 2,849
This means that the Vicon server is not outputting body data. Another user reported a similar problem on the forum and claimed to fix it by enabling kinematic data to be output in the real-time stream.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Vertex shader performance problem Joran Vizard 2 11-17-2008 02:29 AM
5DT Data Glove 5 Ultra Problem bjgold Vizard 1 08-08-2006 05:08 PM
problem with female animations vmonkey Vizard 1 10-07-2005 11:36 AM
sound problem alaa Vizard 7 09-02-2005 02:13 PM
PROBLEM: Picture-in-Picture breaks textures?!? vcarlson Vizard 4 10-05-2004 05:22 PM


All times are GMT -7. The time now is 12:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC