WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Reply
 
Thread Tools Rating: Thread Rating: 5 votes, 5.00 average. Display Modes
  #1  
Old 08-31-2009, 02:24 PM
jde jde is offline
Member
 
Join Date: Jul 2009
Location: Providence RI
Posts: 24
.osg/.ive import - missing geometry & some textures

Hi folks,

I have seen some similar posts regarding missing/damaged textures but nothing on missing geometry. This might be a problem with my 3DS Max settings but I hope it will be of interest to people who work with both programs...

I created a virtual maze using 3DS. Strangely, the outer walls are only visible when I rotate the maze in the 3DS viewport (i.e. they are visible only when the view is such that those walls are not occluding other walls/objects).



I then baked the lighting and exported to .ive using these settings...



But when I import the .ive file into Vizard (bottom of picture 1), I'm missing the same walls that only show up from certain angles in 3DS Max.

Any idea why my geometry isn't getting included in the .ive or why it only shows up from certain angles in MAX? Also, my textures are pretty messed up on some of the objects when I open the .ive in Vizard -- the objects look broken in places and the textures are really strange.

Thanks,
Jon
Reply With Quote
  #2  
Old 08-31-2009, 06:10 PM
Veleno Veleno is offline
WorldViz Team Member
 
Join Date: Sep 2005
Posts: 148
Hi Jon,
By default in most programs, polygons are 1 sided. This is called backface culling an optimization feature that allows the GPU to do basically half of the work then if it drew everything all the time.

To get both sides to show up in vizard, check "2-sided" in the material. To show the backside in 3d studio max, rightclick on an object, select properties, then uncheck backface cull.

If you plan to have any sort of lighting on the object, consider adding a shell modifier to make it solid.

What specifically is happening with the textures? Is it a tiling change? Can you post some side-by-side screenshots showing how the texture looks in max vs vizard?

One thing to check is to make sure gamma control is turned off in Max's preferences when exporting since it currently causes the colors to become corrupted during exports.
Reply With Quote
  #3  
Old 09-03-2009, 08:24 AM
jde jde is offline
Member
 
Join Date: Jul 2009
Location: Providence RI
Posts: 24
Hi Veleno,

Thanks!!

Turning off backface culling worked like a charm. I believe I also needed to check "Force 2-sided" in the rendering options to make sure that the walls show up when rendering the image.

Should I add the same shell modifier to all of the objects in the maze? (i.e. just highlight all objects and use the same shell modifier settings?)

I'll post some screenshots of the texture problems I'm having soon...

Thanks,
Jon
Reply With Quote
  #4  
Old 09-04-2009, 03:18 PM
Veleno Veleno is offline
WorldViz Team Member
 
Join Date: Sep 2005
Posts: 148
Hi Jon -

You should only need to do that on thin objects that you need to see both side of. For something like a poster on a wall for example, you're never going to see the back of it, so it's safe to keep it one sided. Any object that is already "solid" won't need it.

Just mess around and test out different situations a bit, and you'll figure out when it's useful and when it's wasting polygons.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Multiple Textures for Diffuse and Specularity Shader Issue shivanangel Vizard 1 05-11-2009 10:44 AM
Pick porblem with arrays shivanangel Vizard 3 08-27-2007 10:10 AM


All times are GMT -7. The time now is 02:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC