WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Thread Tools Rate Thread Display Modes
Old 05-03-2005, 08:41 AM
tavaksai tavaksai is offline
Join Date: Jul 2004
Posts: 22
Antialiasing polygons


I want to enable antialiasing for all the vrml objects in my application.

I have been able to enable this for simple lines with the commands:


but the polygon equivalent


works only partially. That is, the vrml
objects do seem to get antialiased
but there are transparent lines in all
the objects making the scene look bad.

To see this, try loading the room and table that come with Vizard and enabling antialias.

How could I correctly enable antialiasing for vrml objects?

Reply With Quote
Old 05-03-2005, 10:16 AM
farshizzo farshizzo is offline
WorldViz Team Member
Join Date: Mar 2003
Posts: 2,849
Hi Max,

If you want to anti-alias your entire scene then I recommend using Full Screen Anti Aliasing (FSAA). Most graphics cards support this feature and it is built-in. Just go to your graphics card settings and set the FSAA value to 2x or 4x. You don't have to change any code in your script and it should make your scene look a lot nicer. Let me know if you need any help getting this working.
Reply With Quote
Old 05-03-2005, 01:21 PM
tavaksai tavaksai is offline
Join Date: Jul 2004
Posts: 22
Hey Farshizzo,

Thanks for the tip. I enabled antialiasing
on my graphics card without any

Reply With Quote

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -7. The time now is 09:14 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC