WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 03-15-2011, 01:35 AM
chris_user chris_user is offline
Member
 
Join Date: Feb 2011
Posts: 20
memory handling in vizard

hello,

on our actual scene we have placed a high resolution object, so far it worked. but each time you take a look away from the object and back on it there is always a little interruption in the movement. there is also a framedrop about 50 percent. it seems that it is building it up again. is there a way to prevent that to happen?

thanks

chris
Reply With Quote
  #2  
Old 03-15-2011, 01:46 PM
Jeff Jeff is offline
WorldViz Team Member
 
Join Date: Aug 2008
Posts: 2,458
What is the resolution of the texture? Does the stutter happen if this is the only model loaded in Vizard?
Reply With Quote
  #3  
Old 03-16-2011, 02:33 AM
chris_user chris_user is offline
Member
 
Join Date: Feb 2011
Posts: 20
hello jeff,

the texture is only 1024px by 1024px. I have also tried to bring in the model without any texturing applied, nothing seems different in the behaviour. stuttering is still present.
as long as the model doesn't move out the field of view, everything is fine. does vizard have any kind of override to keep all of the scene geometry even if it's not in field of view?

thanks

chris
Reply With Quote
  #4  
Old 03-18-2011, 03:41 PM
Jeff Jeff is offline
WorldViz Team Member
 
Join Date: Aug 2008
Posts: 2,458
If the number of primitives or drawables is high, then the frame rate will drop when they're in view. How many polygons for this model and what kind of graphics card do you have? Do you see the frame rate drop as the object moves into view and does it stay at that lower rate?
Reply With Quote
  #5  
Old 03-21-2011, 12:27 AM
chris_user chris_user is offline
Member
 
Join Date: Feb 2011
Posts: 20
in the workstation is a quadro 3800, the three models have a polycout of about 2,5 million polygons. we already decreased the total number for the final scene but i still have a little interruption in the viewport.

as long as you don't take a look away from the model the framerate is stable, but if it moves back in view this short stuttering is happening. is there in the code a kind of flag that i can set that vizard keeps all models in cache, even if the view moves away from the model?
Reply With Quote
  #6  
Old 03-22-2011, 02:52 PM
Jeff Jeff is offline
WorldViz Team Member
 
Join Date: Aug 2008
Posts: 2,458
No, there is no command for that. You might try disabling nVidia's power saving mode. Go to Manage 3D settings in the nVidia control panel and look to see if there is a power management setting. If there is one make sure it's set to something like "maximum performance" rather than "adaptive".
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Realistic Light and Shadows Using Vizard and 3DS Max jde Vizard 4 07-13-2012 11:58 AM
Vizard 4 Beta Testing farshizzo Announcements 0 02-01-2011 11:46 AM
Vizard 4 Beta Testing farshizzo Vizard 0 02-01-2011 11:46 AM
vizard memory error durf Vizard 2 08-05-2009 08:28 AM
Vizard tech tip: Using the Python Imaging Library (PIL) Jeff Vizard 0 03-23-2009 12:13 PM


All times are GMT -7. The time now is 04:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC