WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Reply
 
Thread Tools Rating: Thread Rating: 6 votes, 5.00 average. Display Modes
  #1  
Old 06-28-2005, 11:34 AM
marcoleon marcoleon is offline
Member
 
Join Date: Jun 2005
Posts: 17
importing avatars with cal3d

I followed the instructions, but Vizard doesn't recognize the bones or the materials or the mesh from my .cfg file. Does it have anything to do with my using .cmf, .crf, and .csf files instead of the ones in the avatars included in Vizard?

This is the error message I get:

**************************************************
****************************
* VIZARD 2.51c *
* *
**************************************************
****************************

Loading File: tut_ground.wrl
Loading File: Masha.cfg
cal3d : Incompatible file version in loader.cpp(711)
cal3d : Invalid handle as argument in coremodel.cpp(552)
cal3d : Invalid handle as argument in coremodel.cpp(516)
cal3d : Invalid handle as argument in coremodel.cpp(516)
cal3d : Invalid handle as argument in coremodel.cpp(516)
Model::create: ERROR: Can't create a model. Most probable reason is that the core doesn't have any data.
Model::stop: ERROR: The model doesn't have a mixer
cal3d : Invalid handle as argument in skeleton.cpp(103)
__________________
Marco
Reply With Quote
  #2  
Old 06-28-2005, 02:04 PM
tobin tobin is offline
WorldViz Team Member
 
Join Date: Feb 2003
Posts: 251
I doubt it. I suspect right now that the Cal3D exporter you're using is incompatible with the previous version of Cal3D which Vizard uses to import. This will take a day to verify, and if it's the case then we'll need another day to recompile our loader to bring it up-to-date with the latest version of Cal3D.

We will update you shortly.
Reply With Quote
  #3  
Old 06-29-2005, 01:29 PM
tobin tobin is offline
WorldViz Team Member
 
Join Date: Feb 2003
Posts: 251
We've verfied that it is the exporter/importer version mismatch. We'll now try to update Vizard importer for you.
Reply With Quote
  #4  
Old 06-30-2005, 02:41 PM
tobin tobin is offline
WorldViz Team Member
 
Join Date: Feb 2003
Posts: 251
Updating the Cal3D loader is more involved than we had guessed, which means we require 2 weeks to provide an update. In the meantime, you could try finding a license to Max5 or 6 and use the old exporter. Or, you could send your Character Studio file to us at support@worldviz.com and we a stop-gap service of exporting the model for you.
Reply With Quote
  #5  
Old 06-30-2005, 03:03 PM
marcoleon marcoleon is offline
Member
 
Join Date: Jun 2005
Posts: 17
would i be able to use 3ds max 7 still if i got an older version of the cal3d exporter?
would that work?
__________________
Marco
Reply With Quote
  #6  
Old 07-01-2005, 10:23 AM
tobin tobin is offline
WorldViz Team Member
 
Join Date: Feb 2003
Posts: 251
The older Cal3D did not include precompiled binaries for Max 7. What you could do which would be faster on our end would be to send us the Max 7 SDK "include" and "lib" folders. This would allow us to quickly recompile the old Cal3D exporter to work with Max 7 rather than making you wait for the longer term solution in which we rebuild our loader to handle the new Cal3D exporters. Does that make sense?

When you install Max, an option is to install the Max SDK. When you do, a folder will appear in your Max installation called Max SDK. In there you'll find the "include" and "lib" subfolders. These are what you could zip and email to support@worldviz.com. These are helper files that allow developers to create products (plug-ins) for Max.
Reply With Quote
  #7  
Old 07-01-2005, 11:33 AM
marcoleon marcoleon is offline
Member
 
Join Date: Jun 2005
Posts: 17
Yes, I sent the zip file just now.
__________________
Marco
Reply With Quote
  #8  
Old 11-22-2005, 08:37 AM
rdotsch rdotsch is offline
Member
 
Join Date: Jul 2005
Location: The Netherlands
Posts: 20
Max 8

Hi!

I've got exactly the same problem. Only I'm using 3ds max 8 (but an exporter binary of Cal3d 0.10, compiled for 3ds max 7, which might be the problem). I get these errors:

Code:
Loading File: fromthetop\testy.cfg
cal3d : Incompatible file version in loader.cpp(711)
cal3d : Invalid handle as argument in coremodel.cpp(552)
cal3d : Invalid handle as argument in skeleton.cpp(103)
Model::create: ERROR: Can't create a model. Most probable reason is that the core doesn't have any data.
Model::stop: ERROR: The model doesn't have a mixer
Regards,

Ron

Last edited by rdotsch; 11-22-2005 at 08:41 AM.
Reply With Quote
  #9  
Old 11-22-2005, 01:05 PM
farshizzo farshizzo is offline
WorldViz Team Member
 
Join Date: Mar 2003
Posts: 2,849
Hi,

Vizard 2.5 uses an older version of Cal3D, so it won't be compatible with any files created using the 0.10 exporter. We have the Cal3d exporters for the version Vizard uses. However, we don't have the 3ds Max 8 sdk. I can give you the version of our exporter for Max 7, but I don't know if it will work. Send me an email at lashkari@worldviz.com if you would like these files
Reply With Quote
  #10  
Old 04-10-2006, 12:36 PM
deeply_immersed deeply_immersed is offline
Member
 
Join Date: Nov 2004
Posts: 4
cal3d status

Hi-

I'm trying to figure out what version of Max I need if I want to do cal3d exporting for Vizard. What's the status for cal3d exporting? Can I export from max 7 with the old cal 3d exporter? or from max 8 with the new exporter?
Reply With Quote
  #11  
Old 04-10-2006, 12:45 PM
farshizzo farshizzo is offline
WorldViz Team Member
 
Join Date: Mar 2003
Posts: 2,849
Hi,

We have generated the Cal3D exporter that will be compatible with Vizard for 3D Max versions 5 through 8. I just noticed that the plugins are not on the download page. It may take a while to put them there, in the meantime you can email me at lashkari@worldviz.com and let me know which versions you need the plugin for and I will provide them directly to you.
Reply With Quote
  #12  
Old 04-14-2006, 04:35 PM
deeply_immersed deeply_immersed is offline
Member
 
Join Date: Nov 2004
Posts: 4
Great

I just checked back and they're on the download page. Thanks.
Reply With Quote
  #13  
Old 04-27-2006, 01:59 PM
deeply_immersed deeply_immersed is offline
Member
 
Join Date: Nov 2004
Posts: 4
trouble with cal3d exporters

Hey-

I downloaded the cal3d exporter for 3dmax 8 and put it in the plugins folder, but when I started max, the dll and dle failed to initialize.
Reply With Quote
  #14  
Old 04-27-2006, 02:34 PM
farshizzo farshizzo is offline
WorldViz Team Member
 
Join Date: Mar 2003
Posts: 2,849
Hi,

Are you also placing the cal3d.dll file in the same directory as the exporter?
Reply With Quote
  #15  
Old 04-28-2006, 11:31 AM
deeply_immersed deeply_immersed is offline
Member
 
Join Date: Nov 2004
Posts: 4
Yes. All three files are there. Should they be?
Reply With Quote
  #16  
Old 04-28-2006, 05:48 PM
farshizzo farshizzo is offline
WorldViz Team Member
 
Join Date: Mar 2003
Posts: 2,849
Hi,

Yes, the Cal3d importer/exporter plugins depend on the cal3d.dll file. I'll do some testing here to see what the problem is. In the meantime, try replacing the cal3d.dll file that came with the plugins with the cal3d.dll file that is included in your [Vizard25]/bin directory.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 04:13 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC