WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Reply
 
Thread Tools Rating: Thread Rating: 2 votes, 5.00 average. Display Modes
  #1  
Old 09-04-2013, 04:15 AM
williamchappell williamchappell is offline
Member
 
Join Date: Aug 2013
Posts: 11
Polhemus Fastrak

Hey, after reading though some of your tutorials I've got the following code:

Code:
import viz
import vizact
import viztracker

viz.setMultiSample(4)
viz.fov(60)
viz.go()

lab = viz.addChild('lab.osgb')

PORT_FASTRAK = 1
fastrak = viz.add('fastrak.dls')
Which gets me the error:
Code:
Loading File: lab.osgb
fastrak.dls              	Polhemus Fastrak v1.0
** ERROR: Failed to connect to Polhemus Fastrak over USB or COM1
** Load Time: 0.26 seconds
The fastrak is working correctly, to my knowledge, as the bundled software can connect and display the data.
Is there anything else I need to do to ensure a connection the the fastrak?

Thanks, Will.
Reply With Quote
  #2  
Old 09-05-2013, 07:09 AM
Kevin Chiu Kevin Chiu is offline
WorldViz Team Member
 
Join Date: Feb 2012
Posts: 26
Hi,

Can you try this code and see if the Fastrak is connected?
Code:
import viz
import vizact
import viztracker

viz.setMultiSample(4)
viz.fov(60)
viz.go()

lab = viz.addChild('lab.osgb')

polhemus = viz.add('polhemus.dle')
fastrak = polhemus.addFastrak(port=1,baudRate=115200)
Reply With Quote
  #3  
Old 09-06-2013, 05:02 AM
williamchappell williamchappell is offline
Member
 
Join Date: Aug 2013
Posts: 11
Hey Kevin, I tried your code, however I'm getting the error:

Code:
Loading File: lab.osgb
polhemus.dle             	Polhemus Extension
** ERROR: Failed to connect to Polhemus Fastrak over USB or COM1
** ERROR: Failed to create extension sensor with polhemus.dle
** Load Time: 0.25 seconds
Reply With Quote
  #4  
Old 09-09-2013, 04:12 AM
Kevin Chiu Kevin Chiu is offline
WorldViz Team Member
 
Join Date: Feb 2012
Posts: 26
Hi,

What kind of interface you are using for connecting Fastrak with the computer? is that serial port or USB?
Also you may need to check about if the PiMgr application is running at the same time.
If it does, please quit the PiMgr and try to run Vizard again.
If you still run into trouble for connecting Fastark, please let me know.

Thanks.
Reply With Quote
  #5  
Old 09-09-2013, 05:36 AM
williamchappell williamchappell is offline
Member
 
Join Date: Aug 2013
Posts: 11
Hey Kevin, we're currently connected via USB.

PiMgr has also been closed before trying to run the code.

Will.
Reply With Quote
  #6  
Old 09-12-2013, 05:57 AM
Kevin Chiu Kevin Chiu is offline
WorldViz Team Member
 
Join Date: Feb 2012
Posts: 26
Hi Will,

Sorry for the late reply.
It now seems more like an USB driver issue for me, are you using the latest Fastrak USB driver on the computer for connecting the Fastark?

Since we know that older versions of the Fastrak USB driver were unstable with Vizard, I think it will also be good for that if you can contact Polhemus support for checking the version of your USB drivers are the newest one.

Please let me know if you still run into problem even using the latest Fastrak USB driver.
Thanks.

Best Regards,
Kevin
Reply With Quote
  #7  
Old 09-18-2013, 12:22 PM
farshizzo farshizzo is offline
WorldViz Team Member
 
Join Date: Mar 2003
Posts: 2,849
Can you try the following code instead:

Code:
polhemus = viz.add('polhemus.dle')
fastrak = polhemus.addFastrak(port=1,baudRate=115200,legacy=False)
We added experimental support for the newer FasTrak protocol and the legacy flag controls whether to use the older or newer protocol.
Reply With Quote
  #8  
Old 09-20-2013, 07:57 AM
williamchappell williamchappell is offline
Member
 
Join Date: Aug 2013
Posts: 11
Hey guys, I've tried the latest code, but still get the following error:

Code:
******************************************************************************
** Loading trackingtest.py
******************************************************************************
Loading File: lab.osgb
polhemus.dle             	Polhemus Extension
** NOTIFY: Connected to Unknown device over USB: 1 sensors detected
** ERROR: Failed to connect to a FasTrak: Device not found
** ERROR: Failed to create extension sensor with polhemus.dle
** Load Time: 2.60 seconds
Reply With Quote
  #9  
Old 09-25-2013, 03:08 AM
williamchappell williamchappell is offline
Member
 
Join Date: Aug 2013
Posts: 11
Hey, I've been in contact with the guys at Polhemus, and they seem fairly confident that the issue isn't on their end.

Is there anything else I can try?

Thanks.
Reply With Quote
  #10  
Old 09-27-2013, 10:40 AM
farshizzo farshizzo is offline
WorldViz Team Member
 
Join Date: Mar 2003
Posts: 2,849
I believe the issue is that the newer Polhemus FasTrak drivers identify themselves as a different device, so our existing plugin is unable to detect them properly (hence the "Connected to unknown device" message). We've updated our plugin to support these newer models. Try downloading/installing the latest version of Vizard and see if it fixes the issue.
Reply With Quote
  #11  
Old 09-27-2013, 10:41 AM
williamchappell williamchappell is offline
Member
 
Join Date: Aug 2013
Posts: 11
Thank you for your reply.

I will head into work tomorrow and give it a try!

Will.
Reply With Quote
  #12  
Old 09-28-2013, 08:49 AM
williamchappell williamchappell is offline
Member
 
Join Date: Aug 2013
Posts: 11
Thank you! It works like a charm now
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Polhemus Liberty Latus connecting error Yang Vizard 2 02-13-2013 11:52 AM
Integration of Polhemus fastrak transmitter data to Basic guy free rig in maya abhilash Vizard 0 04-15-2010 10:18 PM
Polhemus woes Enlil Vizard 2 09-02-2008 09:09 AM
fastrak Steve_HT Vizard 17 07-20-2007 09:51 AM
Support Polhemus Insidetrack and Cybermind Visette Pro HMD mspusch Vizard 1 03-08-2003 11:14 AM


All times are GMT -7. The time now is 12:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC