WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Reply
 
Thread Tools Rating: Thread Rating: 2 votes, 5.00 average. Display Modes
  #1  
Old 06-24-2010, 07:53 PM
Weihua An Weihua An is offline
Member
 
Join Date: Apr 2008
Posts: 2
Unhappy question about NVIDIA 3D vision

I have a question about NVIDIA 3D vision, which is puzzling me for half a month. No one can help me to solve it, so I come this forum to seeking help, the question is follows.

I have a Samsung SyncMaster 2233RZ LCD Monitor, and Geforce 3D vision shutter glasses. the display card in my computer is Nvidia Quadro fx 1700, my os is win7. I want to use these environment to achieve active stereo.

I installed all the drivers, and the shutter glasses have passed the driver test. I also used them to play some games, such as "Ballance 3D" and "Need For Speed". the stereo effect is very cool. But when I use them in vizard, the problem is coming.

In vizard, I directly use the following code:
viz.go(viz.QUAD_BUFFER|viz.FULLSCREEN)
then the input/ output window will show the following prompt, and the program do not show stereo pictures.
Producer::VisualChooser: the requested visual is not available, trying to relax attributes...


and then, I adjust the display control panel as follows.
stereo-display mode = generic active stereo
stereo-enable=On
stereo-swap eyes=On

after that, when I run the program again, the monitor can display the ghost pictures, but the shutter glasses can not work, I still see the ghost through the glasses. that seems the nvidia shutter glasses can not work for vizard.

can anybody help me? why the nvidia shutter glasses do not work in vizard? are there any wrong setting?
Reply With Quote
  #2  
Old 06-25-2010, 11:46 AM
Jeff Jeff is offline
WorldViz Team Member
 
Join Date: Aug 2008
Posts: 2,457
As far as we know, 3D Vision does not support OpenGL applications on GeForce cards, so it will not work with Vizard.

It may work with Quadro cards, that's where the viz.QUAD_BUFFER flag would be used.
Reply With Quote
  #3  
Old 06-25-2010, 07:27 PM
Weihua An Weihua An is offline
Member
 
Join Date: Apr 2008
Posts: 2
thanks Jeff very much!

my display card is NVIDIA quadro fx1700, that is a Quadro card. and I also writed the following code in my vizard script. but the shutter glasses can not work. I don't know why.

viz.go(viz.QUAD_BUFFER|viz.FULLSCREEN)
Reply With Quote
  #4  
Old 06-26-2010, 03:46 PM
hosier hosier is offline
Member
 
Join Date: Feb 2007
Posts: 31
I also have a Samsung 2233, the NVidia shutter glasses and a Quadro 3800. Once loading the Quadro drivers for the glasses, I've had no problems getting it to work using viz.QUAD_BUFFER.

One thing that might be tripping you up is that most of the games that work with this setup use Direct3D for the stereo 3D, so once you've installed the drivers, there isn't anything you have to do. For OpenGL based stereo 3D, you still have to go into the card setup and activate OpenGL 3D. You'll also have to set how the glasses are connected, either via the USB port or by the 3D VESA port on the graphics card.

I'm guessing you haven't done that yet, and that's why you are getting the:

Producer::VisualChooser: the requested visual is not available, trying to relax attributes...

message. It's saying it isn't able to turn on the OpenGL 3D mode.

I'd start with verifying that the OpenGL 3D mode is enabled and the proper connection method is set for the glasses.


Aaron
Reply With Quote
  #5  
Old 06-28-2010, 03:38 PM
wayne wayne is offline
Member
 
Join Date: May 2008
Location: Santa Barbara, CA
Posts: 9
Also make sure that after you change any of the Quadro 3D settings, that you exit and restart Vizard. If Vizard is not restarted after enabling stereo 3D, your request for viz.QUAD_BUFFER will still not work, giving the impression that something else is wrong, when in fact you just need to restart Vizard.

regards,
Wayne
Reply With Quote
  #6  
Old 08-02-2010, 06:49 AM
tanith tanith is offline
Member
 
Join Date: Jul 2010
Posts: 2


In the nVidia control panel, set it to "Generic active stereo (with NVIDIA IR)" as shown above - its the 4th one down.

Ensure that your display is set to 120hz, where it says 60hz on the screenshot:

Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
stereo vision with nvidia 3d vision mina5500 Vizard 2 10-23-2010 08:53 AM
NVIDIA 3D vision question atamasan Vizard 3 03-29-2010 08:31 PM
eMAGIN and NVIDIA FX2700m bebebaby424 Vizard 1 12-08-2009 05:41 PM
Nvidia 3D vision Bundle jalvarez Vizard 2 07-12-2009 11:55 AM
General question and question regarding arrays dan12345 Vizard 1 01-15-2008 10:15 AM


All times are GMT -7. The time now is 08:10 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC