WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 11-27-2018, 05:43 AM
natstj natstj is offline
Member
 
Join Date: Aug 2018
Posts: 6
Oculus Stuttering after minutes of use

I'm having an issue where the display in my oculus stutters very badly after anywhere from a few minutes to an hour of usage. I only see this affect in the oculus and not on the monitor.

My update time, cull time, and draw time are all under the frame rate. The GPU time is also under the frame rate. However, my update time increases gradually over time (still under the frame rate when all three are combined though). Does anyone have ideas why this is happening or what may cause the update time to gradually increase?

Is this likely a code execution issue or a hardware issue? I'm using this for academic purposes so I'm really depending on high performance.

Thank you!
Reply With Quote
  #2  
Old 11-27-2018, 07:01 AM
natstj natstj is offline
Member
 
Join Date: Aug 2018
Posts: 6
** Slight edit, I think it actually does show up on the monitor, but to a much lesser extent.
Reply With Quote
  #3  
Old 11-28-2018, 09:11 PM
Jeff Jeff is offline
WorldViz Team Member
 
Join Date: Aug 2008
Posts: 2,431
A few questions:

1. What is the sum of update, cull, and draw times?
2. What does the update time increase to?
3. If you just load the scene models without any other code is there stutter?
4. What kind of graphics card do you have?
Reply With Quote
  #4  
Old 11-29-2018, 04:41 AM
natstj natstj is offline
Member
 
Join Date: Aug 2018
Posts: 6
1. When it starts to stutter the sum is around 4 ms with the update time being about 2.5 ms. The oculus has a frame rate of 90, so I figured as long as the sum of cull, draw, and update times were under 12 ms it would be ok. The GPU is under 1 ms.

2. When it starts to stutter it increases to about 2.5, but if I leave it running despite the stutter, I've seen it go up to around 6. This is after maybe 60 minutes.
Another thing that confused me was that for the first minute or so, the frame rate reading is really high, (as in over 300) though it does settle to 90.

3. When I just load scene models, I don't notice any stutter. Though I was surprised to see that the update time was about 0.4 ms. It seemed high since I was not running any code.

4. NVIDIA geForce GTX 1080

Thank you so much!
Reply With Quote
  #5  
Old 11-30-2018, 09:11 AM
natstj natstj is offline
Member
 
Join Date: Aug 2018
Posts: 6
Thanks for your help, the problem was a misunderstanding of the remove() function.

I was calling myNode.remove() without realizing it only removed the item from the vizard engine, and didn't remove the python object. This was causing the update time to increase each trial.
Reply With Quote
Reply

Tags
oculus, performance, stuttering, vizard

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Which Vizard5 version to use with Oculus Rift DK2? rdkirkden Vizard 3 06-16-2017 09:33 AM
Oculus Rift + Vizard help required sukhpreet Vizard 1 01-03-2017 11:52 AM
Xbox controller and Oculus DK2 prilpi Vizard 17 03-28-2016 06:00 AM
3D text oculus for right to left languages bbb Vizard 2 01-16-2016 08:02 AM
Oculus runtime disrupts clustering to mirror DK2 display performlabrit Vizard 1 01-23-2015 08:00 AM


All times are GMT -7. The time now is 05:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC