WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 01-30-2008, 02:00 PM
shivanangel shivanangel is offline
Member
 
Join Date: Feb 2006
Location: New Jersey
Posts: 180
Strange Wii Mote error...

Hi,

I recently started working with the Wii mote with Vizard. However, after a windows XP computer failure I found the code no longer worked.

While I was running code my system locked up and crashed.

Now when I try to use even the simplest wiimote compatible code, I get the following error:

Traceback (most recent call last):
File "C:\Program Files\WorldViz\Vizard30/python\vizact.py", line 2738, in __ontimer
val = event.call()
File "C:\Program Files\WorldViz\Vizard30/python\vizact.py", line 2564, in _callStatic
return self.func(*self.args,**self.kwargs)
File "TestStand_V_2_0_wiiMite.py", line 76, in UpdatePointer
x1,y1 = mote1.posIR
TypeError: unpack non-sequence

It is not code dependent, since even if I copy and paste the code directly from your example it still gives me the same thing.

Any ideas what this might be?

I uninstalled Vizard and upgraded to the new one for Q1 of 2008 and still have this error. Could it be a Bluetooth problem and maybe I need a reinstall there?

Thanks,
George D. Lecakes Jr.
Reply With Quote
  #2  
Old 01-30-2008, 03:25 PM
farshizzo farshizzo is offline
WorldViz Team Member
 
Join Date: Mar 2003
Posts: 2,849
That error is probably a side effect of the plugin not connecting to the wiimote. Try using the following code to connect to a wiimote:
Code:
wiimote = wii.addWiimote()
if not wiimote.valid():
    viz.message("Failed to connect to wiimote")
    sys.exit()
This will display an error and exit the script if a wiimote could not be found. If this is the case, then you need to make sure your Bluetooth driver is connected to the wiimote.
Reply With Quote
  #3  
Old 02-06-2008, 12:01 PM
shivanangel shivanangel is offline
Member
 
Join Date: Feb 2006
Location: New Jersey
Posts: 180
I tried your script, and you are right. It is unable to detect the Wii mote every time.

However, I have tried utilizing several blue tooth stacks and two different blue tooth devices (both of which work on other computers).

I've tried BlueSoleil, Windows Blue tooth stack, and finally Toshiba's stack and I still can not get vizard to recognize the wii mote.

In addition, I've tried other wiimote programs such as GlovePIE and they are able to recognize the remotes when plugged in.

Is there anything else you could think of that could cause the problem?

I did, after several failures, get it to work when 2 motes were plugged in a one of them had an LED lit up while the other went dead.

However, there was almost no real time responce. THe arrow would jump from place to place seemingly at random.

Thanks,

George
Reply With Quote
  #4  
Old 02-06-2008, 08:26 PM
farshizzo farshizzo is offline
WorldViz Team Member
 
Join Date: Mar 2003
Posts: 2,849
I have tested the Wiimote plugin using a Kensington Bluetooth 2.0 USB adapter with the WIDCOMM drivers and they work very well. I haven't tried with any other hardware, so there could be some issues with it.

The on-screen arrow is based on the IR data, which requires the IR sensor bar. You will need to make sure there are no other IR sources in the room as well. Is the inertial/orientation data responsive?
Reply With Quote
  #5  
Old 03-13-2008, 10:59 AM
shivanangel shivanangel is offline
Member
 
Join Date: Feb 2006
Location: New Jersey
Posts: 180
To kind of close this thread,

I experimented and determined that there is definately something wrong with our VR computer. It won't respond to any stacks or bluetooth devices.

I went and used a different computer and I found a few interesting things.

I used a D-Link bluetooth adaptor and BlueSoleil trial version 5 and was able to get one WiiMote to function. I was never able to get more than one to function.

Several times I would have to restart the application because the wiimotes did not connect to vizard correctly. Also, there was sometimes long pauses (5 seconds at most) before the demo would respond to the nunchuk.

Could you please tell me what Bluetooth stack you are using? I've tried a toshiba bluetooth stack which recognizes the wiimotes,

However when I run vizard it shuts the blinking LEDs on the wiimotes off and says it can't connect to them.

Any thoughts? I'm trying to use these things as the new interface device for our VR machine.

We do have infared bars set up, we purchased them from Nintendo. The problem is definately something to do with the stack and vizard communicating.

I've tried both XP and Vista and have the same problem with only one connecting with BlueSoleil and nothing working with a toshiba stack.

Thanks,

George
Reply With Quote
  #6  
Old 03-13-2008, 11:14 AM
shivanangel shivanangel is offline
Member
 
Join Date: Feb 2006
Location: New Jersey
Posts: 180
Sorry, Update.

Only by using your Kensington bluetooth device with the stack it provides was I able to get the Bluetooth to finally work.

I thought it woul dbe interesting for you to know that somethings work half way and others not at all.

~George
Reply With Quote
  #7  
Old 03-13-2008, 11:59 AM
farshizzo farshizzo is offline
WorldViz Team Member
 
Join Date: Mar 2003
Posts: 2,849
I use the WIDCOMM 4.0.1.2400 drivers and haven't had too many problems with them. The Kensington USB adapter supports up to 7 connections, and I was able to use 7 wiimotes simultaneously in my script.

I've noticed that the drivers will occasionally drop a connection, and pairing the wiimote with the driver can be a pain sometimes. I haven't been able to test with other dongles/drivers, so I don't know what the best combination is.
Reply With Quote
  #8  
Old 07-23-2008, 08:11 AM
digitaldarklord digitaldarklord is offline
Member
 
Join Date: Jul 2008
Location: Baarn
Posts: 9
Send a message via MSN to digitaldarklord Send a message via Skype™ to digitaldarklord
There are basically 2 links which are interesting

1) Based on C# code (create you own wrapper)
http://vitalbytes.com/wiimote/

2) If I read this thread this has a lot to do with calling
the right stacks and the right bluetooth hardware
There's a list on http://wiihacks.blogspot.com/2006/12...s-as-your.html

Enjoy!
Reply With Quote
  #9  
Old 02-18-2009, 01:32 PM
purdue_vr purdue_vr is offline
Member
 
Join Date: Oct 2008
Posts: 5
Wii mote in worldviz

Hi I am trying to connect a Wii mote to my vizard code.
I have same issues like the program does not recogonize the wii mote.

I am using a voice star bluetooth dongle and i actually did not use any software. I jus plugged in the Bluetooth dongle and my computer recogonized it. I was also able to add the wii mote to my bluetooth devices by pressing 1+2 buttons simultaneously.

Now i have a few questions which is not letting me work further with this:
1. After the wii mote is connected to the computer does the LED keep blinking or does it stop after sometime? cause mine stops in a few seconds.
Does that still mean that the wii mote is connected?

2. What should i do so that my vizard program recogonizes the wii mote. Am i missing something here? should i install some software?

Thanks. I would appreciate any response that could be related.

Regards
Priya
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
error in actionPool[thread] v-zbigy Vizard 1 10-12-2007 04:21 PM
Error Message Jerhy Vizard 1 02-28-2006 02:59 PM
Error Tracking Vygreif Vizard 1 10-03-2005 05:50 PM
Error when playing wav files...? vjonshih Vizard 1 05-23-2005 01:21 PM
The error window that couldn't FlyingWren Vizard 2 12-02-2003 09:23 AM


All times are GMT -7. The time now is 04:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC