WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Reply
 
Thread Tools Rating: Thread Rating: 7 votes, 5.00 average. Display Modes
  #1  
Old 09-13-2013, 02:50 PM
dproeder dproeder is offline
Member
 
Join Date: May 2013
Posts: 3
Light Baking in 3DS Max causing models to render with seams and transparent faces

After Lightbaking, my models inside of Vizard seem to have dark texture seams, and parts of the models become transparent.

I am creating my models and applying textures in Maya. I then import those models in to Max using the .fbx file format. If I export from Max as an .osgb into Vizard, all the models are being drawn just fine (although unlit.)

After doing a Render to Texture light bake using Mental Ray, I get errors inside of Vizard using the same .osgb export settings.

I have concluded the following

1. My models and materials from Maya are fine.
2. Exporting from 3ds Max before any light baking is fine.
3. Baking Lights in 3ds Max causes models to render badly


Possible Issues

- My shell materials have become messed up and I need to remake/reset them

- The materials I end up with from my Maya to Max workflow do not play with Mental Ray

- Not enough Texture Space on the Light Map for proper rendering in Vizard

- Incorrect Render to Texture/OSGB export setttings


Here are some pictures and settings.

Unlit and Unbaked Railing with no Problems


Lit and Baked Railing with Seams and unwanted Transparency

(I'm letting Render to Texture layout my UVs. A lot of wasted space)


Render to Texture Results


Light Map


Render to Texture Settings
Reply With Quote
  #2  
Old 09-17-2013, 07:45 PM
Veleno Veleno is offline
WorldViz Team Member
 
Join Date: Sep 2005
Posts: 148
Hi dproeder,

Transparency: Check whether your baked textures have an alpha channel. Alpha is automatically picked up by Vizard as transparency when used as a diffuse texture. If this is the case, change your texture output settings to prevent an alpha channel from being created when baking textures. If you are baking transparent objects as well, bake only those with transparency enabled.

Bad Unwrap Spacing: I have the same complaint actually. Use the attached Maxscript instead to automatically unwrap the selected objects instead of using the one in Render to Texture.

Mental ray can have issues with thin and small UV islands. If an island would render smaller than a pixel wide (before any padding) Mental Ray deems it unimportant and fails to render it. Normally it wouldn't matter, because the padding would compensate. Unless something has been changes since I last checked, your options are:
1. Use a larger texture size
2. Use more supersampling
3. Keep detailed objects or parts of objects separate from objects with large flat areas and only give a higher resolution to just these special objects.
4. Switch to a 3rd party renderer that does not have this problem (eg. VRay, which is what we use).

Both 1 and 2 greatly increase the time and RAM needed to render a map. 3 uses 1 & 2, but is more targeted. 4 can be expensive but can save enough time/headaches to be worth it.
Attached Files
File Type: zip Unwrap Selection.zip (958 Bytes, 510 views)
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC