WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 04-04-2014, 10:41 AM
shivanangel shivanangel is offline
Member
 
Join Date: Feb 2006
Location: New Jersey
Posts: 182
Question Enabling Effects in Vizard 5?

I'm trying to move the model that I see working properly in the Inspector into Vizard, however I'm not getting any of the shader effects.

My script is as simple as possible:
import viz
viz.go()
coolingCylinder = viz.add('StaticModels_New//CoolingCylinder.OSGB')

When I right click and go to properties to load the OSGB in the Inspector from Vizard, everything looks fine.

However in Vizard, all the shader effects seem to just be composited one on top of the other as if them were just being blended as normal textures.

Is there a setting to turn on effects that is not on by default?

Nothing jumped out at me in the help doc to do this.

Thanks,
~George
Attached Thumbnails
Click image for larger version

Name:	VizardHelp.jpg
Views:	722
Size:	358.7 KB
ID:	636  
Reply With Quote
  #2  
Old 04-07-2014, 07:48 AM
shivanangel shivanangel is offline
Member
 
Join Date: Feb 2006
Location: New Jersey
Posts: 182
Exclamation

Still not able to get these effects in the Inspector to work Vizard side.

Looked further into your documentation and found this: <node3d>.generateEffects(viz.EFFECTGEN_OSGMAXEXP ) but it doesn't change anything for my object.

Any ideas?
Reply With Quote
  #3  
Old 04-07-2014, 10:44 AM
masaki masaki is offline
Member
 
Join Date: Jan 2008
Posts: 63
Hello,

To enable the effects, please try:
Code:
import vizfx
model = vizfx.addChild('...')
You may also need to enable lighting on the model with the usual:
Code:
model.enable( viz.LIGHTING )
Masaki
Reply With Quote
  #4  
Old 04-07-2014, 11:03 AM
shivanangel shivanangel is offline
Member
 
Join Date: Feb 2006
Location: New Jersey
Posts: 182
That worked for the ambient occlusion map, however I'm not getting any lighting (specular in particular).
I added the model.enable(viz.LIGHTING) however I noticed no change.
Neither the headlamp seems to be doing anything or a basic directional light.

I also tried adding a light in the inspector and saving the model, but with nothing showing up in Vizard.

Code:
import viz
import vizfx
viz.enable(viz.EFFECTGEN_OSGMAXEXP)

viz.setMultiSample(4)
viz.go(viz.FULLSCREEN)
coolingCylinder = vizfx.addChild('StaticModels_New//CoolingCylinder.OSGT')
coolingCylinder.enable( viz.LIGHTING) 
viz.sensitivity(10, 0.75)

viz.addLight()
~George
Reply With Quote
  #5  
Old 04-07-2014, 11:07 AM
shivanangel shivanangel is offline
Member
 
Join Date: Feb 2006
Location: New Jersey
Posts: 182
Ok... Just started looking through the vizfx module and found your new generic light type and that worked.

Any plans on making this stuff the standard in Vizard, or will I have to go through this process for every vizfx model I want to bring in?

~George
Reply With Quote
  #6  
Old 05-01-2014, 11:51 AM
performlabrit performlabrit is offline
Member
 
Join Date: Oct 2013
Posts: 77
Light baked into object?

Hey Shiva, maybe you can help me. I've just gone through the same struggle, but now have working dynamic lighting.

However, I find that my object created in 3DSMax is dimly lit even in the absence of light sources, when it should be totally black.

Any thoughts?
Reply With Quote
  #7  
Old 05-09-2014, 08:14 AM
Jeff Jeff is offline
WorldViz Team Member
 
Join Date: Aug 2008
Posts: 2,466
It sounds like the global ambient lighting is still affecting the object. You will need to set the ambient color to black to completely disable all coloring of the object:
Code:
vizfx.setAmbientColor(viz.BLACK)
This should ensure the object is completely black in the absence of lights and emissive properties.
Reply With Quote
  #8  
Old 05-21-2014, 02:49 AM
virtualBox virtualBox is offline
Member
 
Join Date: Apr 2014
Posts: 1
Hi,

This is another question about 3ds Max in Vizard.I am new to Vizard. I designed a 3D model building in 3ds Max 2014. I am using Vizard 5 32bit. I want to see the same file in Vizard. When I bake the file using Complete Map with Diffuse color, as shown in World Viz articles, I see that all the textures got baked properly but after I export this file to Vizard, there is Diffuse texture on diffuse color like in the picture link. Everything looks red and green.
https://www.dropbox.com/s/0eqw54nua8...fuseColor3.png
Reply With Quote
  #9  
Old 05-27-2014, 04:13 AM
Jeff Jeff is offline
WorldViz Team Member
 
Join Date: Aug 2008
Posts: 2,466
I was not able to see the image you linked to. Do you get a better result if you load the model without using the effects command?
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Realistic Light and Shadows Using Vizard and 3DS Max jde Vizard 4 07-13-2012 10:58 AM
Vizard 4 Beta Testing farshizzo Announcements 0 02-01-2011 10:46 AM
Vizard 4 Beta Testing farshizzo Vizard 0 02-01-2011 10:46 AM
Vizard tech tip: Using the Python Imaging Library (PIL) Jeff Vizard 0 03-23-2009 11:13 AM
Particle effects in Vizard v-Salik Vizard 1 09-20-2007 03:42 PM


All times are GMT -7. The time now is 01:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC