WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 03-11-2015, 06:52 AM
willpower2727 willpower2727 is offline
Member
 
Join Date: Feb 2015
Posts: 39
Unhappy installing

Hi I am trying to figure out how to install "Yappi" (yet another python profiler) to profile a multi-thread script. The installation instructions from Yappi say I can install using "easy_install" or "pip install" methods.

I am running Vizard 4 (Python 2.7), which appears to have the pip package already installed. However, I can't figure out how to use it. I've tried the following commands in the python shell:

python -m pip install yappi-0.94.tar.gz

py -2.7 -m pip install yappi-0.94.tar.gz

I get nothing but a syntax error. Can anyone help me figure out my error? How can I make use of the pip package?
Reply With Quote
  #2  
Old 03-17-2015, 02:27 AM
Jeff Jeff is offline
WorldViz Team Member
 
Join Date: Aug 2008
Posts: 2,455
It seems that package requires building binary files from the source and a compatible compiler such as Visual Studio.
Reply With Quote
  #3  
Old 03-17-2015, 07:25 AM
willpower2727 willpower2727 is offline
Member
 
Join Date: Feb 2015
Posts: 39
Thanks! i'll look into using VS to build
Reply With Quote
  #4  
Old 03-17-2015, 10:00 AM
Jeff Jeff is offline
WorldViz Team Member
 
Join Date: Aug 2008
Posts: 2,455
Are you planning to upgrade to Vizard 5? If so, the unofficial binary for yappi listed on this page installs fine with the version of pip included with Vizard 5.
Reply With Quote
Reply

Tags
install, package, pip, profile, yappi

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Difficulties installing packages with Package Manager smadansingh Vizard 11 05-29-2015 07:00 AM
problem installing vizard 4.0 alpha Vizard 1 04-01-2013 11:29 AM
OSG Exporter 9.6 Kettle Vizard 11 01-26-2011 12:56 AM
Installing Cal3D or OSG exporter unabhan Vizard 2 07-22-2009 08:17 AM


All times are GMT -7. The time now is 01:51 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC