WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

 
 
Thread Tools Rating: Thread Rating: 7 votes, 4.86 average. Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 06-01-2006, 11:05 PM
John P John P is offline
Member
 
Join Date: Jun 2006
Posts: 8
quad_buffer cluster

I'm working with a networked cluster, 3 pc's with quadro gfx cards. They have frame synchronization in effect and my intention is to implement active stereo across all 3 screens. So far I have had mixed success.

I find the line:
viz.go(viz.QUAD_BUFFER)
will launch the cluster but active stereo is only enabled on the cluster master.

On the other hand the line:
viz.go(viz.ANAGLYPHIC)
does in fact launch the entire cluster into anaglyphic stereo.. Just not quite what I'm after.

Another approach I have tried is to enable stereo explicitly for each of the clients.
Something like:
viz.pushmask(viz.CLIENT1)
viz.clusteroffset(-50, 0, 0) # yaw, pitch, roll
viz.stereo(viz.QUAD_BUFFER)
viz.popmask()
#and repeat for each client
viz.go()


In this case it seems the statement viz.stereo is ignored. But again, this syntax works with other stereo modes like anaglyphic.

Any info on how to get this working or about a limitation I've bumped into would be appreciated. The hardware should handle this and I'm keen to see it up on the projection system.

Thanks,
John.
Reply With Quote
 

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 12:09 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Copyright 2002-2023 WorldViz LLC