WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 06-08-2015, 09:57 AM
Trever.R Trever.R is offline
Member
 
Join Date: May 2015
Posts: 4
Question Shadow Map Bakes with vizfx.addchild

Hello, recently I worked out how to get normal maps and specular maps to work properly in vizard by adding assets through the vizfx.addchild command. However by using that, it seems to not be able to take the shadow map bakes that I have created. Whenever I try to export a file with a bake on it, the baked map ends up tiled all over the object. Does anyone have any idea how to go about this, or is it not possible to use baked maps with vizfx?
Reply With Quote
  #2  
Old 06-08-2015, 10:30 AM
Jeff Jeff is offline
WorldViz Team Member
 
Join Date: Aug 2008
Posts: 2,462
If you're using the shader workflow, the light map should be placed in the Ambient color slot rather than the Self-Illumination slot.
Reply With Quote
  #3  
Old 06-09-2015, 08:33 AM
Trever.R Trever.R is offline
Member
 
Join Date: May 2015
Posts: 4
I tried putting the map into the ambient color slot, and the results are way too bright (see attached image). Any idea whats causing that? I didn't have any lights coded in when I ran it so it can't be that.
Attached Thumbnails
Click image for larger version

Name:	Light Map EX.png
Views:	501
Size:	503.2 KB
ID:	709  
Reply With Quote
  #4  
Old 06-09-2015, 08:47 AM
Trever.R Trever.R is offline
Member
 
Join Date: May 2015
Posts: 4
And here is the light map I generated. Its generated as a tga, I just screenshoted it here because tga isnt supported on the forums.
Attached Thumbnails
Click image for larger version

Name:	Light Map.png
Views:	491
Size:	314.8 KB
ID:	710  
Reply With Quote
  #5  
Old 06-09-2015, 10:35 AM
Veleno Veleno is offline
WorldViz Team Member
 
Join Date: Sep 2005
Posts: 148
Hi Trever,

What's going on here is that your lightmap is currently overexposed. In the the shader 50% brightness is treated as the neutral exposure value, so anything lighter will be brighter than the original texture and anything darker will darken it. This allows for the scene to represent areas of intense light, which is impossible when only darkening the scene.

This is similar to using the "Self-Illumination Scale: 2x" export option that could be used with the old workflow.

The solution here is to adjust the exposure and re-render your lightmaps so everything you want to have a neutral exposure has a brightness of 50%. You final lightmap should look something like the attached image.
Attached Thumbnails
Click image for larger version

Name:	Untitled-3.jpg
Views:	502
Size:	46.8 KB
ID:	711  
Reply With Quote
Reply

Tags
baked, lighting vizard osgb, shadowmaps, vizfx

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
shadows in mirror chris_user Vizard 0 02-17-2011 03:37 AM
Shadow Module and Shaders mruss7 Vizard 1 07-27-2010 01:00 PM
how to change shadow direction? shahramy Vizard 2 05-05-2010 09:37 PM
setEuler method of Shadow module omidbrb Vizard 1 02-22-2010 09:35 AM
RE: Shadow Module nige777 Vizard 2 05-08-2008 04:52 PM


All times are GMT -7. The time now is 09:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC