WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 01-23-2006, 10:26 AM
Johannes Johannes is offline
Member
 
Join Date: Jan 2005
Posts: 143
Problem with rendering tube-wrl-file

Hi,
I created a tube with blender but it does not show up correct in vizard. Only shows the tube from the outside, when you are inside the tube, it does not show it.

Best,
Johannes
Attached Files
File Type: zip tubeinner.zip (3.6 KB, 608 views)
Reply With Quote
  #2  
Old 01-23-2006, 08:56 PM
tobin tobin is offline
WorldViz Team Member
 
Join Date: Feb 2003
Posts: 251
This is a common pitfall, one that almost everyone experiences at sometime. The default mode for most 3D graphics rendering pipes is to cull (i.e., not draw) surfaces that are facing away from the viewpoint. Often this dumb strategy works and pays off well in performance. But when you want to view the inside AND outside of an object, the method is problematic. You can either export your object using a double-sided material (I don't know for sure that blender supports this) or within Vizard disable backface culling with the <node3d>.disable command.

Here's a more detailed explanation of backface culling:

http://gpwiki.org/index.php/3D:Backface_Culling
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 06:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC