WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 03-08-2006, 07:40 AM
perselletje perselletje is offline
Member
 
Join Date: Sep 2005
Posts: 7
python 2.4 instead of 2.3?

Is there a way to use vizard with python 2.4 instead of 2.3? I need lots of extra modules, some of which do not work in python 2.3. I managed to use vizard with the other modules in python 2.3, but when I try it in 2.4 it complains that the python version is wrong.
Reply With Quote
  #2  
Old 03-08-2006, 10:16 AM
farshizzo farshizzo is offline
WorldViz Team Member
 
Join Date: Mar 2003
Posts: 2,849
Hi,

Vizard 2.5 is compiled with Python 2.3, there is no way to use it with 2.4. Vizard 3.0 will use Python 2.4, but that won't be released for at least a few months. Which particluar module is not working for you? Most python addons provide you with different versions.
Reply With Quote
  #3  
Old 03-09-2006, 02:58 AM
perselletje perselletje is offline
Member
 
Join Date: Sep 2005
Posts: 7
The problem is not that I can't find the other modules for python 2.3, it's more that I need lots of them and they are all installed for python 2.4. So it just seems a bit inefficient to me to have to change everything back to an older version of python, while in a few months I will probably have to turn it back to the newer version when vizard starts using 2.4. Is it not possible to compile the current version of vizard for 2.4? I have no idea how much work that is, or if this needs changes, but maybe it is possible and a more efficient solution than changing all the rest.
Reply With Quote
  #4  
Old 03-09-2006, 04:31 AM
perselletje perselletje is offline
Member
 
Join Date: Sep 2005
Posts: 7
Or maybe, which would even be much better, it is possible to have something like other modules, you can install in python so you can run the program with vizard without having to open the gui. For the license it cannot be a problem since it checks for the license when you load the vizard module. Would that be possible you think?
Reply With Quote
  #5  
Old 03-09-2006, 11:07 AM
farshizzo farshizzo is offline
WorldViz Team Member
 
Join Date: Mar 2003
Posts: 2,849
Hi,

It is possible to recompile Vizard and all of its plugins to link against python 2.4. However, I'm not in the position to make this sort of decision. You would have to take this up with support@worldviz.com.

You can already run Vizard without opening the GUI. It is possible to use other Python editors to program Vizard scripts, but the main Vizard module still uses Python 2.3, so it wouldn't make any difference.
Reply With Quote
  #6  
Old 03-10-2006, 05:05 AM
perselletje perselletje is offline
Member
 
Join Date: Sep 2005
Posts: 7
Ok, I'll do that.
Thanks a lot!
Reply With Quote
  #7  
Old 03-14-2006, 01:44 AM
perselletje perselletje is offline
Member
 
Join Date: Sep 2005
Posts: 7
Hi,
I sent a mail to the support, but I don't get any response, except that I got a 'ticket'. Is this normal?
Reply With Quote
  #8  
Old 03-14-2006, 11:06 AM
tobin tobin is offline
WorldViz Team Member
 
Join Date: Feb 2003
Posts: 251
Sorry that your support query didn't get answer. It was a tough question and has raised several internal discussions. I'll see to it that you receive a response shortly.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 04:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC