WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 04-03-2012, 01:35 AM
Huib Huib is offline
Member
 
Join Date: Nov 2010
Posts: 10
Question [win7] Bad quality when not on primary monitor or window has no focus

My situation is as follows:

What we have:
  • a vizard window on one monitor (or actually on multiple monitors / HMD, but the problem also occurs on a single monitor)
  • a graphical user interface on the other monitor (that interacts with vizard over a tcp connection)

The computer runs on Windows 7 with an nVidia Geforce GTX 680.

The problems
With vsync turned on and triple buffering turned off in the nvidia settings, we get the best results, but only when:
  • vizard runs fullscreen on the primary display (that we set as primary in the windows settings)
  • the vizard window has focus (when clicked outside the window, for instance somewhere on the GUI, we encounter the problems described below)

When one of these is not the case we get problems, especially when the image contains a lot of motion, which manifest differently, depending of Aero is turned on or off:

With Aero off: terrible tearing occurs (we also tried turning it on in vizard instead of the nvidia settings, with the same results).

With Aero on: movement is extremely choppy

Although the frame rate never drops below 60 FPS.

The solution (?)
To work around these problems, we tried the current setup:
  • a matrox card (to get a single primary display)
  • a dvi splitter (to be able to clone one of the HMD glasses)
  • a seperate computer for the GUI to run on (so the vizard window can preserve focus)

As you might understand, we'd rather replace one of these hardware components by a software solution, so my question is:

Does anyone know of either a nicer solution for either the focus problem or the primary display problem? (or both )


P.S.
what we've already tried:
  • running the GUI on the onboard intel GPU
  • reducing the scene's polygons as much as possible
  • set the maximum framerate to 60 FPS (by setting viz.max_frame_rate)

Last edited by Huib; 04-03-2012 at 01:40 AM.
Reply With Quote
  #2  
Old 04-03-2012, 01:48 AM
Huib Huib is offline
Member
 
Join Date: Nov 2010
Posts: 10
Quote:
Originally Posted by Huib View Post
With Aero off: terrible tearing occurs (we also tried turning it on in vizard instead of the nvidia settings, with the same results).
With "it", I meant vsync (somehow I was only able to edit my post for a couple of minutes?)
Reply With Quote
  #3  
Old 04-04-2012, 04:07 PM
farshizzo farshizzo is offline
WorldViz Team Member
 
Join Date: Mar 2003
Posts: 2,849
If your script is running at a solid 60 FPS, then vsync is most likely on. Can you make sure power management is not enabled in the nVidia 3D settings. The setting should be called "Power management mode" and you will want to make sure it is set to "Maximum performance".

Also, this is not ideal, but try enabling the 'viz.glFinish' option:
Code:
viz.setOption('viz.glFinish',1)
Let me know if any of these make a difference.
Reply With Quote
  #4  
Old 04-06-2012, 12:43 AM
Huib Huib is offline
Member
 
Join Date: Nov 2010
Posts: 10
Quote:
Originally Posted by farshizzo View Post
If your script is running at a solid 60 FPS, then vsync is most likely on.
Yes no doubt about that. When I disable vsync, framerate rises to about 90 FPS. And it does its job perfectly, as long as the 2 "requirements" are met.

Quote:
Can you make sure power management is not enabled in the nVidia 3D settings. The setting should be called "Power management mode" and you will want to make sure it is set to "Maximum performance".
Quote:
Also, this is not ideal, but try enabling the 'viz.glFinish' option:
Code:
viz.setOption('viz.glFinish',1)
Why is this not ideal? It didn't seem to have any effect. But I guess it could have some benefits in certain conditions? (and some negative side effects?)

Quote:
Let me know if any of these make a difference.
I tried both (also combined), but unfortunately none of it appeared to increase quality and the problems still remained.
Reply With Quote
  #5  
Old 04-11-2012, 09:29 AM
farshizzo farshizzo is offline
WorldViz Team Member
 
Join Date: Mar 2003
Posts: 2,849
The glFinish option is not ideal because it blocks at the end of the frame for the GPU to finish rendering. This can reduce the framerate in some cases because you lose the parallelization of the CPU and GPU.

If you disable vsync, what is the reported frame rate in Vizard? If you are getting tearing with vsync on, then this is most likely a driver issue. Do you have the latest drivers for your graphics card installed?
Reply With Quote
  #6  
Old 04-12-2012, 06:34 AM
Huib Huib is offline
Member
 
Join Date: Nov 2010
Posts: 10
Quote:
Originally Posted by farshizzo View Post
If you disable vsync, what is the reported frame rate in Vizard? If you are getting tearing with vsync on, then this is most likely a driver issue. Do you have the latest drivers for your graphics card installed?
Without vsync, the framerate goes somewhere from 70 to 100 or even higher, depending on which scene is loaded or which part we're in.

I have the latest (stable) drivers, downloaded from the nvidia website.
Reply With Quote
Reply

Tags
choppy, focus, primary, tearing, windows 7

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC