WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 04-22-2008, 01:43 PM
theuberk theuberk is offline
Member
 
Join Date: Jul 2007
Posts: 44
Inertiacube 2 problem

Hi,

Something strange happened today with our inertiacube2. This has never happened before, and the code did not change. The cube is linked to the MainView using viz.link and link.setMask.

The problem is that the orientation data seems to be wrong. When standing still initially, the data seems to be fine, but as soon as the cube moves, the data becomes incorrect. For example, when we turn around 180 degrees, the MainView seems to rotate about 200 degrees or sometimes up to 270 degrees.

Another strange thing is that if we stand still after this movement, the cube seems to attempt correct itself (i.e. the MainView rotates without us actually moving) after about 3 - 10 seconds. Sometimes this correction is accurate, and sometimes it is even worse.

Is this a known problem? If so, are there any known solutions? Is there something wrong with our inertiacube? Could this be caused by magnetic interference?
Reply With Quote
  #2  
Old 04-22-2008, 04:03 PM
farshizzo farshizzo is offline
WorldViz Team Member
 
Join Date: Mar 2003
Posts: 2,849
Interference could definitely be a cause of this. Have you tried calibrating your InertiaCube using the Calibration Tool that comes with the Intersense installation CD? This tool helps tune your InertiaCube to the interference of your current environment.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
5DT Data Glove 5 Ultra Problem bjgold Vizard 1 08-08-2006 04:08 PM
problem with female animations vmonkey Vizard 1 10-07-2005 10:36 AM
sound problem alaa Vizard 7 09-02-2005 01:13 PM
Problem with newer Intersense Inertiacube 2 esmith4 Vizard 3 03-18-2005 08:13 AM
PROBLEM: Picture-in-Picture breaks textures?!? vcarlson Vizard 4 10-05-2004 04:22 PM


All times are GMT -7. The time now is 09:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC