WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 01-07-2016, 09:35 AM
lklab lklab is offline
Member
 
Join Date: Mar 2015
Posts: 20
Oculus Rift - Start with same viewpoint

Currently when running my program the viewpoint is dependent on the initial position of the oculus and it is very difficult to get it perfectly leveled. How can I get it so that the starting position is the same each time it is run? So that each participant views the exact same thing?

Thank you!
Reply With Quote
  #2  
Old 01-10-2016, 10:26 PM
Jeff Jeff is offline
WorldViz Team Member
 
Join Date: Aug 2008
Posts: 2,462
If you're using vizconnect then you can set a vizconnect viewpoint. See this thread for example code.
Reply With Quote
  #3  
Old 01-11-2016, 12:27 PM
lklab lklab is offline
Member
 
Join Date: Mar 2015
Posts: 20
thanks! that is what i was looking for. What version of vizard do i need to run it on? It works on the computer where I have the vizard 5 trial. The other one only has version 4 and gives me an error that the vizconnect module is not found.

(if I update, is 5 backwards compatible?)
Reply With Quote
  #4  
Old 01-12-2016, 01:55 AM
Jeff Jeff is offline
WorldViz Team Member
 
Join Date: Aug 2008
Posts: 2,462
Vizconnect requires Vizard 5. Most Vizard 4 code will run fine in Vizard 5. The Vizard 5 upgrade guide describes major changes between 4 and 5 that could affect scripts.
Reply With Quote
  #5  
Old 01-13-2016, 09:17 AM
lklab lklab is offline
Member
 
Join Date: Mar 2015
Posts: 20
umm this works great but how do i remove the weird glove thing?

is there a way to achieve the same effect in vizard 4?
Reply With Quote
  #6  
Old 01-13-2016, 10:34 AM
lklab lklab is offline
Member
 
Join Date: Mar 2015
Posts: 20
basically what I want to do is to just reset the yaw and keep the others constant
Reply With Quote
  #7  
Old 01-14-2016, 08:05 AM
Jeff Jeff is offline
WorldViz Team Member
 
Join Date: Aug 2008
Posts: 2,462
To remove the glove:

Go to the vizconnect advanced configuration
Go to the avatars tab
Press the settings button and uncheck the box for right hand

It sounds like you just need a heading reset. In vizconnect, go to the trackers tab and press the Mappings button. Map an input signal to the resetHeading function. See the resets tech tip for more information.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Matching the field of view between Desktop and Oculus Rift DK2 Qiliang He Vizard 11 06-29-2020 07:33 AM
Oculus Rift Drift teklab Vizard 20 04-01-2016 07:57 AM
Multiple post-process effects with oculus rift lklab Vizard 2 03-13-2015 01:48 PM
Oculus Rift connection problem mshukun Vizard 1 10-01-2014 12:15 PM
Oculus Rift Fullscreen teklab Vizard 6 05-21-2014 06:11 AM


All times are GMT -7. The time now is 07:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC