WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 11-22-2015, 12:55 PM
lklab lklab is offline
Member
 
Join Date: Mar 2015
Posts: 20
Vizard avatar textures have blurred edges

I am trying to make an animated tree. Right now if I export as osgb, the textures come out sharp pixel to pixel. This is what I want. But when exporting it with cal 3d as an avatar, the textures are blurred. This is a problem because I want my edges to be sharp but this is causing a blurry haze to appear around my textures.

Anyone know whats wrong?

Thank you!
Reply With Quote
  #2  
Old 12-02-2015, 03:49 PM
Veleno Veleno is offline
WorldViz Team Member
 
Join Date: Sep 2005
Posts: 148
Hi Iklab,
I may be able to help you here.
Can you start by uploading a couple screenshots of the issue you're seeing? It isn't clear from the text.
Reply With Quote
  #3  
Old 12-06-2015, 02:34 PM
lklab lklab is offline
Member
 
Join Date: Mar 2015
Posts: 20
This is the weird effect I'm getting.

close up

this is the osgb that looks sharp.
Attached Thumbnails
Click image for larger version

Name:	Capture.PNG
Views:	587
Size:	110.8 KB
ID:	736   Click image for larger version

Name:	Capture2.PNG
Views:	637
Size:	124.6 KB
ID:	737   Click image for larger version

Name:	Capture3.PNG
Views:	601
Size:	122.7 KB
ID:	738  
Reply With Quote
  #4  
Old 12-11-2015, 01:33 PM
Veleno Veleno is offline
WorldViz Team Member
 
Join Date: Sep 2005
Posts: 148
Hi lklab,
Unfortunately avatar materials do not currently support exporting unfiltered textures like you are using in your scene. You may be able to turn it on manually through code.

The checkerboard effect you are looking at is an artifact of multisampling alpha - a technique that prevents draw order artifacts. Normally this shouldn't be on in your model unless you've explicitly turned on GL_SAMPLE_ALPHA_TO_COVERAGE_ARB, but it's possible that it's being set by your graphics card.

For references, this is how you would normally turn it on, with higher sampling giving smoother results.

Quote:
import viz

viz.setMultiSample(4)
#higher values increase quality but decrease framerate.
#usually set between 2 and 16

viz.go()

transModel = viz.add('model.IVE') #add a model, call it tranModel

GL_SAMPLE_ALPHA_TO_COVERAGE_ARB = 0x809E
transModel.disable(viz.BLEND)
transModel.enable(GL_SAMPLE_ALPHA_TO_COVERAGE_ARB)

viz.clearcolor(viz.GRAY)
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
add 3dmax avatar in Vizard Gonzalo Vizard 1 09-23-2011 04:44 AM
Vizard 4 Beta Testing farshizzo Announcements 0 02-01-2011 10:46 AM
Clarification on CAL3D Avatar Animation in Vizard shivanangel Vizard 2 11-22-2010 07:16 AM
Vizard tech tip: Using the Python Imaging Library (PIL) Jeff Vizard 0 03-23-2009 11:13 AM
Max -> Vizard, Two Sided Textures shivanangel Vizard 5 12-04-2008 03:15 AM


All times are GMT -7. The time now is 01:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC