WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 02-25-2008, 11:12 AM
theuberk theuberk is offline
Member
 
Join Date: Jul 2007
Posts: 44
Strange Rendering Lag Spikes

Hi,

I seem to be having some strange lag spikes when running my simulation where the frame rate will drop down to and below 30fps. It's strange because I know the computer I'm using can handle the graphics processing (as the frame rate is usually at least 60fps) and most of the time when I'm experiencing these frame rate drops, simply pressing F4 to show the fps will fix the problem. I've turned off all data collection, shadows, and tried almost everything I could think of to fix the problem. This makes me believe that it must be something at a lower level. I do have custom events refreshing each update, but if these events were the problem, I'd think that the low frame rate would be constant..

Any ideas of what the problem might be?
Reply With Quote
  #2  
Old 02-25-2008, 01:39 PM
farshizzo farshizzo is offline
WorldViz Team Member
 
Join Date: Mar 2003
Posts: 2,849
It's hard to tell what the problem is. Do you have a small sample script that reproduces this behavior?
Reply With Quote
  #3  
Old 02-26-2008, 06:27 AM
theuberk theuberk is offline
Member
 
Join Date: Jul 2007
Posts: 44
Alright, well I thought that it might just have been a common problem or something. After reading your post and realizing that it wasn't, I checked over my code and realized that the problem is that my custom events are too inefficient. Is there any easy to get event condition checks to run on a seperate thread?
Reply With Quote
  #4  
Old 02-26-2008, 09:55 AM
farshizzo farshizzo is offline
WorldViz Team Member
 
Join Date: Mar 2003
Posts: 2,849
What are you doing in your event condition checks? You can start a thread by using the viz.director() function, but it might not be too useful considering how Python threading works.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Water rendering... help! k_iwan Vizard 13 04-04-2014 11:57 AM
Any way to increase rendering resolution v-Salik Vizard 3 09-12-2007 04:57 PM
Buttons Not rendering to both Eyes in 3d shivanangel Vizard 2 05-24-2007 06:58 AM
Strange Speak animation and VRML rendering zoltantoth Vizard 2 04-19-2007 10:24 AM
Texture map rendering problem JRichizzle Vizard 4 03-04-2004 07:20 AM


All times are GMT -7. The time now is 11:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC