WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 08-18-2009, 10:33 PM
atamasan atamasan is offline
Member
 
Join Date: Jul 2009
Posts: 26
Question Problem of hand model(using sensors).

Hello.
I'm trying to move hand model using 16 patriots(for my right hand).
So I made codes and run the codes. But the result was not good.

Fingers bends to the strange direction.
I tried to solve the problems, and I think there are problems in my initialization part. But I couldn't find them.

Could you please tell me hint?
This is the flow of my codes.

import viz
import math
viz.go()
right_h=viz.add('hand.cfg')

#get 16 sensors
pat01=viz.addSensor('patriot')
.
.
pat16=viz.addSensor('patriot')

#get hand bones
rbt_00=right_h.getBone('bone thumb 0-0')
.
.
rb=right_h.getBone('bone ~ROOT')

#calculate inverse matrix from sensors's data, manually(if framenumber=1)
inv01~inv16

#make rotation matrix from each sensor's data
Rrot01~Rrot16

#Multiplication
R_01=inv01*Rrot01
.
.
R=16=inv16*Rrot16

#get Euler angles for each sensor from the Matrix(R_01~R_16)
#and link Euler angles to each sensor
l_r_01=viz.link(pat01,rbt_01)
.
.
l_r=viz.link(pat16,rb)

#finally, use the MASK command(Because I need only ORIENTATION DATA)
l_r_01.setMask(viz.LINK_ORI)
.
.
l_r.setMask(viz.LINK_ORI)
[FIN]

I think I should do that more easily, but I'm confused now...

Thank you for reading my message.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Vertex shader performance problem Joran Vizard 2 11-17-2008 01:29 AM
export problem bazelaisr Vizard 2 05-28-2008 10:19 AM
5DT Data Glove 5 Ultra Problem bjgold Vizard 1 08-08-2006 04:08 PM
problem with female animations vmonkey Vizard 1 10-07-2005 10:36 AM
PROBLEM: Picture-in-Picture breaks textures?!? vcarlson Vizard 4 10-05-2004 04:22 PM


All times are GMT -7. The time now is 05:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC