WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 01-10-2009, 11:14 AM
bharatbhushan bharatbhushan is offline
Member
 
Join Date: Jan 2009
Location: Mumbai
Posts: 3
problem in using xsens motion trackers in Vizard

hello I am new to the Vizard software and started to face problems
I am using xsens MTx motion trackers which is connected through XBUS master. Right now I am connecting the XBUS master via USB on COM 10. I have written following script in Vizard for accessing the sensor data
--------------------------------------------------------------
import viz
viz.go()
#Create xsens extenstion
xsens = viz.add('xsens.dle')

#Connect to first available Xsens MT device
sensor = xsens.addMT(port=10,baudRate=0)

def mytimer( num ):
print sensor.getEuler()

viz.callback( viz.TIMER_EVENT, mytimer )
viz.starttimer( 0, 0.5, viz.FOREVER )
--------------------------------------------------------------

after running the script I am getting
--------------------------------------------------------------
xsens.dle Xsens Extension
** Load Time: 1.01 seconds
[0.0, 0.0, 0.0]
[0.0, 0.0, 0.0]
[0.0, 0.0, 0.0]
[0.0, 0.0, 0.0]
[0.0, 0.0, 0.0]
and so on
----------------------------------------------------------------

so what is the the problem. I have checked that the sensor is connected on COM 10 by running XBUS Example and it is giving the proper orientation data. also the xsens.dle file is present in Vizard pulg-ins directory
--
regards,
bharatbhushan
Reply With Quote
 

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Vizard Enterprise Edition and motion capture aaThomas Vizard 4 10-05-2007 10:31 AM
newbie problem getting vizard to work Colin Vizard 2 11-10-2006 10:54 AM
problem talking to usb device in Vizard Vbents Plug-in development 2 06-15-2006 03:08 PM
Vizard Program Problem - G-Chan Vizard 1 06-13-2005 08:29 AM
Vizard Crashes: causes are hard to determine, possible problem with the viz code vr_boyko Vizard 1 01-07-2005 10:52 AM


All times are GMT -7. The time now is 02:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC