WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 01-16-2009, 10:47 AM
michaelrepucci michaelrepucci is offline
Member
 
Join Date: Jul 2008
Posts: 53
stereo rendering problem/bug

We would like to use frame sequential (active) stereo with shutter goggles to study the perception of depth. (Currently, we are using red/green anaglyphs.) Unfortunately, there seems to be a bug in the Vizard rendering engine that prevents its use in this application. It seems that, with active stereo enabled, the position of a moving object is rendered as equivalent in sequential left and right frames.

For example, say the refresh rate is 100 Hz, an object is moving at 100 meters/second, and at time t=0 (immediately before the first frame) the object is at position x=0. Then what SHOULD happen is that the object is rendered at x=0 on the first (left eye) frame, x=1 on the second (right eye) frame, x=2 on the third (left eye) frame, etc. However, what DOES happen, instead, is that the object is rendered at x=0 for both the first and second frames, x=2 for both the third and fourth frames, etc. This behavior causes moving objects to be perceived at different depths than intended, thus making Vizard unusable for experiments in depth perception with active stereo.

This is clearly a very disappointing discovery. Is there perhaps a patch, fix, or work-around that we could use to get the correct behavior?
Reply With Quote
  #2  
Old 01-21-2009, 11:06 AM
farshizzo farshizzo is offline
WorldViz Team Member
 
Join Date: Mar 2003
Posts: 2,849
How are you enabling active stereo? Are you using quad buffering or some other method? Also, what is the refresh rate of your display and what is the frame rate of the Vizard script (press F4 to display framerate)?

The only built-in support for frame sequential stereo in Vizard is through quad buffering. When quad buffering is enabled Vizard will render to both left/right eyes every frame. It is up to your graphics driver to decide which frame is actually displayed on screen. The behavior I have seen with quad buffered stereo is that alternating frames are displayed to each eye. However, this all assumes that your render time is less than the refresh rate of your display.
Reply With Quote
  #3  
Old 01-21-2009, 11:22 AM
michaelrepucci michaelrepucci is offline
Member
 
Join Date: Jul 2008
Posts: 53
Active stereo is enabled via quad-buffering, by setting the configuration option in the vizcore.cfg file. (We're using an NVidia Quadro FX 3700.) The refresh rate and Vizard frame rate are both 120 Hz. (Though to be more specific, the Vizard frame rate reads as 120 Hz if stereo is disabled, but 60 Hz if quad-buffered stereo is enabled. I figured this was indicating the per eye frame rate, but perhaps Vizard simply can't render the scene fast enough? Given how few objects are in the scene, and the speed of our computer, that would be surprising to me.)

BTW, mostly the stereo "works", by which I mean that for, say, a gaming purpose stuff looks good enough and 3D is clear. But at the fine level of detail we need, the perceptual problem resulting from the incorrectly updated frames becomes apparent.
Reply With Quote
  #4  
Old 01-21-2009, 12:02 PM
farshizzo farshizzo is offline
WorldViz Team Member
 
Join Date: Mar 2003
Posts: 2,849
The behavior you are looking to modify would be controlled by the graphics driver. Have you looked through the nVidia control panel for any settings related to how the swapping occurs?

In your case it seems as though the driver is forcing the application frame rate to half of the refresh rate, thus allowing each frame to be displayed to both eyes. I don't see that behavior with the Quadro FX 560 we have here. When stereo is enabled the application frame rate is equal to the refresh rate, and each eye is displayed every other frame. Can you post a screenshot of your 3D settings in the nVidia control panel, or just post the values of the relevant stereo settings?
Reply With Quote
  #5  
Old 01-26-2009, 08:42 AM
michaelrepucci michaelrepucci is offline
Member
 
Join Date: Jul 2008
Posts: 53
Problem solved. Truly sorry for the trouble.

Turns out that Vizard couldn't render at the full 120 Hz (hitting only 60 Hz instead), because of a bandwidth problem that I'd forgotten had arisen in the past with two devices connected to our video card (see http://www.worldviz.com/forum/showthread.php?t=1634). At some point in the last month, thanks to a firmware update on our projector, we discovered the resolution could be turned up (from 1024x768 to 1280x960). Unfortunately, I forgot to confirm whether the video card could actually handle that size at 120 Hz: apparently not. Thanks for the help!
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
vizcave and quad-buffered stereo michaelrepucci Vizard 7 11-29-2011 11:15 AM
8800 ultra stereo driver Dave Vizard 21 10-25-2009 10:25 AM
emagin stereo vision quadro fx 570 smith11235 Vizard 5 08-05-2008 12:01 PM
Stereo synchronisation djdesmangles Vizard 6 05-21-2008 08:32 PM
SeeReal stereo with separate scenes Jerry Vizard 2 10-18-2005 12:02 PM


All times are GMT -7. The time now is 02:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC