WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 01-10-2009, 11:14 AM
bharatbhushan bharatbhushan is offline
Member
 
Join Date: Jan 2009
Location: Mumbai
Posts: 3
problem in using xsens motion trackers in Vizard

hello I am new to the Vizard software and started to face problems
I am using xsens MTx motion trackers which is connected through XBUS master. Right now I am connecting the XBUS master via USB on COM 10. I have written following script in Vizard for accessing the sensor data
--------------------------------------------------------------
import viz
viz.go()
#Create xsens extenstion
xsens = viz.add('xsens.dle')

#Connect to first available Xsens MT device
sensor = xsens.addMT(port=10,baudRate=0)

def mytimer( num ):
print sensor.getEuler()

viz.callback( viz.TIMER_EVENT, mytimer )
viz.starttimer( 0, 0.5, viz.FOREVER )
--------------------------------------------------------------

after running the script I am getting
--------------------------------------------------------------
xsens.dle Xsens Extension
** Load Time: 1.01 seconds
[0.0, 0.0, 0.0]
[0.0, 0.0, 0.0]
[0.0, 0.0, 0.0]
[0.0, 0.0, 0.0]
[0.0, 0.0, 0.0]
and so on
----------------------------------------------------------------

so what is the the problem. I have checked that the sensor is connected on COM 10 by running XBUS Example and it is giving the proper orientation data. also the xsens.dle file is present in Vizard pulg-ins directory
--
regards,
bharatbhushan
Reply With Quote
  #2  
Old 01-12-2009, 02:47 PM
farshizzo farshizzo is offline
WorldViz Team Member
 
Join Date: Mar 2003
Posts: 2,849
The current version of Vizard does not support the Xbus. We will be releasing a new version soon that will support it.
Reply With Quote
  #3  
Old 01-25-2009, 07:14 AM
bharatbhushan bharatbhushan is offline
Member
 
Join Date: Jan 2009
Location: Mumbai
Posts: 3
Question

As it has been quoted that Q1 2009 release of Vizard supports Xsens Xbus devices. But there is no help on this subject either in the Vizard help or in online tutorial, so please provide the commands and the necessary details to use XSENS XBUS master with Vizard .
Reply With Quote
  #4  
Old 01-26-2009, 05:51 PM
farshizzo farshizzo is offline
WorldViz Team Member
 
Join Date: Mar 2003
Posts: 2,849
If you have an XBUS device on COM 10 with 3 sensors connected, then you need to call xsens.addMT() 3 times. The following code shows how:
Code:
xsens = viz.add('xsens.dle')
sensor1 = xsens.addMT(port=10) 
sensor2 = xsens.addMT(port=10) 
sensor3 = xsens.addMT(port=10)
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Vizard Enterprise Edition and motion capture aaThomas Vizard 4 10-05-2007 10:31 AM
newbie problem getting vizard to work Colin Vizard 2 11-10-2006 10:54 AM
problem talking to usb device in Vizard Vbents Plug-in development 2 06-15-2006 03:08 PM
Vizard Program Problem - G-Chan Vizard 1 06-13-2005 08:29 AM
Vizard Crashes: causes are hard to determine, possible problem with the viz code vr_boyko Vizard 1 01-07-2005 10:52 AM


All times are GMT -7. The time now is 11:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC