WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 03-02-2004, 02:04 PM
JRichizzle JRichizzle is offline
Member
 
Join Date: Mar 2003
Location: Houston, TX
Posts: 43
Question Texture map rendering problem

A couple of questions from a new user of v 2.14:

1) I recently started going through the tutorial scripts (e.g., physics1 and myroom.py), textures are not rendering properly. They only show up as intended when close enough to them. It's as if there is some distance relative to the eyepoint beyond which the textures are not able to render - they will show up as randomly colored pixels of different shades of the color spectrum.

2) In the example script "physics1," the balls are falling way too fast in addition to the texture map rendering problem. I have tried turning on vertical sync in the settings of the video card, but it is not readily apparent as to how to make that change.

I am using a ATI RADEON 9700/9500 Series video card.
Reply With Quote
  #2  
Old 03-02-2004, 06:06 PM
farshizzo farshizzo is offline
WorldViz Team Member
 
Join Date: Mar 2003
Posts: 2,849
Hi,

1) Is this happening with all textures? It sounds like this is a mipmapping problem. I'll test it out with a ATI card here and get back to you on it.

2) To turn on vertical sync you need to go to the OpenGL settings for your driver and enable it. Usually you right-click on the desktop, click Properties, select the Settings tab, then click Advanced. From here you need to find the openGL settings section, which depends on your graphics card and driver. There should be an option "Wait for Vertical Sync", you want to set this to "Always On". You might also want to look into the Mipmap settings while you are on that page, this might fix the texture problem you are experiencing.
Reply With Quote
  #3  
Old 03-03-2004, 07:20 AM
JRichizzle JRichizzle is offline
Member
 
Join Date: Mar 2003
Location: Houston, TX
Posts: 43
Hi,

Yes, all textures are affected (at least those in the tutorial examples). Here is a screen shot of the OpenGL settings window for the ATI Radeon 9700/9500 card.

[QUOTE] There should be an option "Wait for Vertical Sync", you want to set this to "Always On".

Clearly, there is no "Always On" option, hence my confusion. The settings shown in the attachment are the defaults.
Attached Images
File Type: jpg openglsettings.jpg (74.7 KB, 885 views)
Reply With Quote
  #4  
Old 03-03-2004, 04:45 PM
farshizzo farshizzo is offline
WorldViz Team Member
 
Join Date: Mar 2003
Posts: 2,849
Hi,

Which version of the ATI driver do you have? Also, what OS are you using? Over here we have an ATI RADEON 9800 on WinXP and textures show up fine. Vertical sync works fine also, and we even have the "Always On" option. We are using the Catalyst 4.2 drivers downloaded directly from ATI's website. If you aren't using the latest drivers you might want to try that first.
Reply With Quote
  #5  
Old 03-04-2004, 07:20 AM
JRichizzle JRichizzle is offline
Member
 
Join Date: Mar 2003
Location: Houston, TX
Posts: 43
Thumbs up

I updated the driver to the Catalyst 4.2 and everthing works fine now. Thanks very much for your help (I'm sure you've had more challenging problems to solve) !!
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 12:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC