View Single Post
Old 03-17-2014, 04:13 AM
chris2307 chris2307 is offline
Join Date: Nov 2013
Posts: 36

So I guess it may have been installed incorrectly. The people who previously worked with pylink in Vizard 4 did not install it via the package manager but directly linked their project to the pylink directory (as I have tried to do above).

Installing pylink in the Vizard 5 beta means I can now import pylink. However, the previous code breaks and I now see this error.

Traceback (most recent call last):
  File "<string>", line 11, in <module>
  File "C:\Users\Operator\Desktop\Application\src\functions\", line 194, in <module>
  File "C:\Users\Operator\Desktop\Application\src\functions\", line 138, in beginExperiment
  File "C:\Users\Operator\Desktop\Application\src\functions\", line 20, in _setupConnection
    eyelinktracker = pylink.EyeLink()     # Real connection
AttributeError: 'module' object has no attribute 'EyeLink'
The code at which it fails at is:

	if dummy == True:
		eyelinktracker = pylink.EyeLink(None) # open dummy connection
		eyelinktracker = pylink.EyeLink()     # Real connection
I'm getting frustrated now because I feel like I am missing something really obvious here...
Reply With Quote