View Single Post
Old 05-01-2003, 03:36 PM
hotspur1 hotspur1 is offline
Join Date: Mar 2003
Location: Cambridge, MA
Posts: 54
Hi Farshid,

Sorry to bother you again, but I did notice some odd behavior when passing args from the command line. I wanted to pass more than one arg, so I tried grabbing the first one using


Now this works fine according to the Vizard interactive window output, but when I check the DOS command window, it shows up as an empty list! I also get an error that the index is not valid!

As I understand the engine, the script is actually parsed twice, so perhaps the variable is getting lost when sent through the second time!

I tried copying the list to another variable using

arglist = viz.args

but the same behavior occurs. The Vizard window has happy output, but the DOS window shows an empty list. As long as I don't try to access the string, the program will obviously runs, but when I try to access a list member, it obviously can't find it.

Any suggestions?

Reply With Quote