View Single Post
  #14  
Old 04-30-2012, 02:05 PM
Veleno Veleno is offline
WorldViz Team Member
 
Join Date: Sep 2005
Posts: 148
Hi JDE. I've taken a look at your model. Chris, since you're using Vray, I have some tips for you as well.

At a glance, the problem look to be related to baking with Alpha and overlaping UVs. If you're also exporting using DXT1 texture compression, this would explain the odd cut-offs in the model since DXT1 uses 1 bit alpha.

I've attached a few images showing typical bake and export settings, and how the model looks when I bake it and bring it into Vizard. I'll attach the work files in the next post.

In the model I see the following issues:
model
- The original model has unwelded vertices and overlapping faces. It looks like you already fixed most of these in your version of the model.
- The scale transform should be collapsed with reset xform
Chris: It looks like you're using vray, which should still be able to get decent results without doing much cleanup (other than an overall weld)

Unwrapping
- You have too much space between UV islands in the bake version of the UVs. This means you'd need to use a larger texture to get the same texel density on the surface of the model than one that was packed more efficiently. For the baking channel (ch 3), use 60 as the threshold angle and 0.005 for the spacing. I don't recommend letting render to texture do the unwrap for you, because it always wastes space by trying to separate things by material ID. The equivalent in a manual unwrap is to use the Flatten Mapping unwrap type.
- Unwrapping based on normals for channel 1 is fine for the diffuse texture and shouldn't cause problems as along as you aren't trying to bake to this channel.

rendering
Chris:
- It looks like you're baking with vray. Stick to vray's materials and lights to get better results. Some of the standard lights and materials don't play nicely in bakes and renders.
- In Color Mapping, in VRay's render settings, switch the type to gamma correction and set the gamma to 1.8. Also check "linear workflow". This will both adjust the gamma curve of the lighting to match your monitor, and also prevent materials and textures from becoming washed out. This method requires the use of Vray's materials to work properly.
- You can improve the results a little by adding a turbosmooth modifier to your model and setting the render iterations to 2. This is just to affect the way the bake looks - you'll still be exporting the lower-poly model.

baking
- Your edge padding is set to 2. This can cause seams to appear on lower mip levels, since it'll be sampling from the background color. I recommend setting it to 16.
- You are baking to an RGBA, instead of RGB. This will also have problems on lower mip levels. For solid objects, change the map output settings to render without an alpha channel.
- It looks like you're doing it already, but make sure the output material is a Standard:Blinn material. When baking to any kind of completemap, the target map slot should be Diffuse.

exporting
- Looks fine, from what I can see. It would be useful to get a screenshot of the rest of the settings though.
- At the bottom, under "Miscellaneous" make sure "convert units to" is set to Meters. This will make sure any model that is at the intended scale in Max units will also be the right size in Vizard.
Attached Thumbnails
Click image for larger version

Name:	baked_texture.jpg
Views:	971
Size:	142.7 KB
ID:	507   Click image for larger version

Name:	max_render.jpg
Views:	940
Size:	102.2 KB
ID:	508   Click image for larger version

Name:	Model_in_vizard.jpg
Views:	927
Size:	147.1 KB
ID:	509   Click image for larger version

Name:	render-to-texture-settings.jpg
Views:	943
Size:	140.5 KB
ID:	510   Click image for larger version

Name:	Typical OSG-Export-Settings.jpg
Views:	931
Size:	70.8 KB
ID:	511  

Reply With Quote