WorldViz User Forum

WorldViz User Forum (https://forum.worldviz.com/index.php)
-   Precision Position Tracker (PPT) (https://forum.worldviz.com/forumdisplay.php?f=9)
-   -   Failed to connect to intersense (https://forum.worldviz.com/showthread.php?t=3828)

Karma 07-01-2011 11:40 AM

Failed to connect to intersense
 
Hello,

I am trying to set up a 2 camera PPT-X system and for some reason the cameras are not picking up the calibration rig.

I tried running this code
Code:

import viz
viz.go()

PORT_INTERSENSE = 3
isense = viz.add('intersense.dls')

but I get this output
Code:

******************************************************************************
** Loading Test.py
******************************************************************************
intersense.dls                  Intersense Driver v4.0.4
** ERROR: Failed to connect to intersense on port 3.
** Load Time: 3.11 seconds

(the next part pops up when I close the test window)

InterSense Library ver. 4.04 32-bit
Copyright 1998-2007 InterSense Inc.
http://www.intersense.com
Tel: 781-541-6330

Looking for InterSense tracking device number 1.
Please wait ...
InterSense tracker not present

I saw a previous thread that said to check the port, but I think port 3 is the correct one to listen from.
http://i.imgur.com/GcoiI.jpg

At one point one of the camera was detecting the calibration rig but now it just looks like this.
http://i.imgur.com/Xl90a.jpg

Thanks for the help!
-Karma

Jeff 07-01-2011 01:48 PM

Intersense

The following code should autodetect the intersense using the newer intersense.dle plug-in:
Code:

import viz
viz.go()

gallery = viz.addChild('gallery.ive')

isense = viz.add('intersense.dle')
tracker = isense.addTracker()

viz.link(tracker,isense)

You can also specify the port number in the addTracker command, it looks like it could be port 1:
Code:

tracker = isense.addTracker(port=1)
PPT Calibration

It appears there is no signal from the cameras, that's why they show red in PPT Studio. Verify everything is connected properly. If so and the cameras still appear red, contact support@worldviz.com for further assistance.


All times are GMT -7. The time now is 06:54 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC