WorldViz User Forum

WorldViz User Forum (https://forum.worldviz.com/index.php)
-   Vizard (https://forum.worldviz.com/forumdisplay.php?f=17)
-   -   Arabic Characters are not displayed properly (https://forum.worldviz.com/showthread.php?t=5619)

Abood Karkar 01-28-2016 08:56 AM

Arabic Characters are not displayed properly
 
Hi, I am trying to display Arabic letters in my application but letters are not linked to each other. For example, the word "test" in arabic is "تجربة", it is appearing like: ت'ج'ر'ب'ة (without quotes). I already used the function viz.setOption('viz.text.bidirectional',1).

I tried to change the encoding (e.g., UTF8, UTF8 BOM, and so) of the file but invalid characters appear or question marks.

I tried to change different fonts manually like calibri.ttf, arabic.ttf, and so. But none of them showed correct presentation of letters.

Could you tell me please how I can fix this?

Thanks,
Abood Karkar

Jeff 01-29-2016 08:42 AM

Can you post example code that reproduces the issue?

Abood Karkar 01-29-2016 10:27 AM

2 Attachment(s)
Thank you Jeff for your reply.

Please, find attached, the sample code.

Best Regards,
Abood Karkar

Abood Karkar 02-15-2016 01:51 AM

Hello, I am wondering if the Arabic letter issue can be fixed. I did not get any reply and I am limited with time.

Thanks,

Abood Karkar

Jeff 02-16-2016 09:02 AM

I'll check with a developer for suggestions.

Abood Karkar 02-16-2016 11:44 AM

Thank you a lot Jeff in advance, I will wait for your answer

Best Regards,
Abood Karkar


All times are GMT -7. The time now is 06:20 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC