WorldViz User Forum

WorldViz User Forum (https://forum.worldviz.com/index.php)
-   Vizard (https://forum.worldviz.com/forumdisplay.php?f=17)
-   -   Ghosting with Nvidia 3d vision (https://forum.worldviz.com/showthread.php?t=3381)

Trevor 01-24-2011 04:32 PM

Ghosting with Nvidia 3d vision
 
Hello, we are having a problem with severe ghosting using Nvidia's 3D vision kit. We are using a Quadro FX 570 and a Samsung SyncMaster 2233. The driver is configured correctly and we get stereo 3D in vizard using viz.go(viz.QUAD_BUFFER|viz.FULLSCREEN). The problem is that the individual stereo images are partially visible though the glasses, thus creating two ghost images of the object next to the converged image.
We have tried to change the background color, texture, stereo vs non-stereo, etc, but to no avail. Darker backgrounds appear to minimize the ghosting somewhat but not significantly.
Is there a way to adjust the depth of the image in Vizard? It seems that decreasing the distance between the L and R stereo images would minimize the ghosting. Any input would be greatly appreciated, thanks.

farshizzo 01-24-2011 06:29 PM

Have you specified the screen distance in your script?
Code:

# Distance between user and screen (in meters)
viz.MainWindow.screenDistance(2.0)

Also, are the units of your model in meters?

You can also tweak the stereo effect using the viz.MainWindow.fusionDistance command.

Trevor 01-25-2011 01:06 PM

Thanks for the response. You answered my question. It is unfortunate that a balance must be struck between minimizing the ghosting effect and maximizing the stereo depth cues.

mspusch 01-25-2011 01:29 PM

Hi Trevor,

did you get any other 3D applications going with less ghosting/crosstalk?

It sounds like you shutter glasses hardware might not be synchronizing correctly with the screen output frequency, or you have bad shutterglasses or something.

there are the following options

A) most likely the shutter glasses 'shutter frequency' is not corresponding correctly with the monitor/projector output frequency. adjustment to the screen / shutter glasses (frequency, sync settings?) might fix the problems

B) the screen / monitor / screen material has some 'after-effect', i.e. the details from one image 'linger' into the next image, which then would be seen as 'cross talk' between the two eyes

If stereo is setup/working correctly, there should be no crosstalk with shutterglasses, i.e. for example for a 120Hz output frequency, first second image should be seen by one eye and the second one by the other eye, etc. (frame sequential).

we have found that depending on the hardware (monitor/ TV screen / projector) it's sometimes not easy to find this correct configuration, and you might have to call the maker of your screen (samsung) or the glasses.

if you reduce the stereo effect in Vizard (make the eye distance smaller), all that does is to make the two images for each eyes more similar, so there is less 3D (and this might look as if there was less artifacts).

anyways, hope that helps.

Matthias


All times are GMT -7. The time now is 06:06 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC