WorldViz User Forum

WorldViz User Forum (https://forum.worldviz.com/index.php)
-   Vizard (https://forum.worldviz.com/forumdisplay.php?f=17)
-   -   Problem with newer Intersense Inertiacube 2 (https://forum.worldviz.com/showthread.php?t=313)

esmith4 03-17-2005 07:41 AM

Problem with newer Intersense Inertiacube 2
 
We have two of these trackers, bought a year or
more apart. The serial numbers are:
Old: SC2-0208045-D
New: 100-IMU00-0210
SC2-0408427-D

The old one works fine, while the new one is
not being detected by Vizard at all (on one computer)
or only intermittently (on another computer).
Informal testing with the Intersense drivers
show that both seem to work OK. So
evidently there is something in the Vizard
driver that is not working properly with the
newer tracker? Has Intersense made some
minor change in data format or whatever
since we got our older one?

Has anyone else had such a problem with a newer
inertiacube 2?
Vizard 2.17 here.

--Eliot Smith
Indiana University

tobin 03-17-2005 08:47 AM

The Intersense driver that searches across all ports often unfortunately mistakes other devices (especially USB devices) as a valid sensor. The workaround is to tell Vizard the port number on which the IC2 is plugged in. You do this by specifying PORT_INTERSE = XX before the call to add the intersense.dls.

Here's an example:

PHP Code:

PORT_INTERSENSE 3
ori 
viz.add('intersense.dls'

This would instruct Vizard to look on COM3 for the Intersense tracker. If you're using a USB-based IC2, you need to figure out which COM port that USB port is getting mapped to.

Please say if you need further assistance.

esmith4 03-17-2005 09:07 AM

That fixed it, at least the one or two times we
tried it -- thanks!
Evidently the difference between the older and
newer cubes is in some aspect that makes the
older one easier for the driver to find than the
newer one... strange. But telling it which
port now lets it find both.

--Eliot Smith

tobin 03-18-2005 08:13 AM

Thanks for letting us know all is well.


All times are GMT -7. The time now is 07:28 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC