WorldViz User Forum

WorldViz User Forum (
-   Vizard (
-   -   Avatars creation........ (

k_iwan 06-07-2006 12:28 AM

Avatars creation........

Is there a tutorial how to create an avatar in XSI / Blender?
My concern is not the actual modeling process. I can model pretty OK.
I was browsing through the People Pak and none of the model would be suitable for my project. Actually, they all look too clean, like people in the office. What I want to create is somewhere between butcher <-> Garbageman.

What I want to know is how to prepare an avatar for Vizard.
How do I set up the animation? do I put All animations in one timeline? or do I split them up in non linear animation editor? does it have number of armature/bone limit? Do I animate run as in movie production (translation+running animation) or in games (running on the spot and use script to translate)? Do I need extra bones to attach static object to the avatar? let say, the avatar is holding a garbage can?

I think I've asked too many things in one go. Thanks for your help.


k_iwan 07-03-2006 04:25 AM

Blender Exporter....
Hi All,

Blender Exporter to Cal3D format seems to be broken...
I searched blender forums and most people are having problem with it. Even the patched exporter doesn't work ... I'll have another Look. :(

Is "Character Studio" the only way to go to get animations in Vizard :confused:



Gladsomebeast 07-03-2006 12:50 PM

We have little experience using other programs besides 3ds Max to export to Cal3D. I did a little digging and it seems that some people are successfully exporting Cal3D avatars from blender. I would suggest that you keep plugging away at the Blender solution.

Keep us in the loop on your progress!

k_iwan 07-03-2006 05:52 PM

Blender option....
I sure will...!!


k_iwan 07-08-2006 04:26 AM

another progress..... (screenshot attached)
1 Attachment(s)
Here's another progress...

I managed to successfully export a model from blender to cal3d. the current cal3d exporter (v.0.9) that comes with blender is broken. There's an updated version in blender forum (v1.1)

By the time I loaded the .cfg in Vizard2.5 trial.. it crashed. I look in the .cfg file the exporter genereated.. and everything seems normal. The model which I created is very simple; a small worm wth only 6-9 bones, 1400 polys.

I tried these following formats with some basic animations;
...md2 ... vizard fails to load the model.
...OSG ... vizard only loads the model.. no animation
...flt ... Vizard loaded up ok, but displayed nothing...
...cfg (cal3d from blender) ... vizard crashed...
...ac3d format ...vizard loaded the model ok.. no animations
...lwo ...vizard reported something error with the file.. did not load model
...3ds ...vizard refused to load.. there's is something fishly about blender's 3ds exporter...

Well... that's the update for today... thanks for reading. I provided a screenshot of my model with the skeletons visible. Then again.... does vizard only import bipeds?


tobin 07-18-2006 09:23 PM

It's possible that this updated blender/cal3d exporter is new than that contained in Vizard R2. If you like, you can email and request download instructions for Vizard R3 beta. R3 uses the newer version of cal3d and this might resolve your problem.

k_iwan 07-20-2006 10:22 PM

I'll try it with Vizard3 beta...

Actually, I do have vizard3 beta, installed at home, I don't know how many days are left, but.. why didn't I try it with vizard3 beta?!?!?!

I'll have another go with Vizard3 beta, and I'll keep you informed.


(...Iwan then hums..Battle Hymn of the Republic... ...again...)

tobin 07-21-2006 11:00 AM

Thanks. I'm definitely interested in hearing what success you have using Blender as a avatar creation tool.

k_iwan 07-24-2006 06:09 AM

I'm confused, how many different version of Cal3d out there?

I opened up 'female.cfg' that comes with vizard3 and I compared it with 'test.cfg' which I produced from blender.

(1) under female.cfg;
skeleton is identified with .csx
animations are identified with .cax
meshes are indentified with .cmx

(2) with blender exporter I don't get these file formats.
from blender I can only export in HTML or in Binary formats, and
I would get these files;
skeleton is identified with .csf (html) or .xsf (binary)
animations are identified with .caf (html) or .xaf (binary)
meshes are indentified with .cmf (html) or .xmf (binary)

So yeah.. I tried both format and vizard crashes after specifying the object name under stage. You know, after you specify a .cfg and vizard will ask you for a name for the object. Vizard crashes at this point. I'm assuming because these formats are different and IF (I'm assuming) the content of .xsf = .csx, vizard wouldn't crash everytime I load the .cfg file.

oh well..., I've done my testing, and will look again sometime next week. If I find anything new, I'll post it here.


(Iwan then hums and listens to "Battle Hymns of the Republic", stryper version)

tobin 07-27-2006 10:38 AM

Would you send sending us your blender files and any links you found on the cal3d exporters that aren't immediately obvious. We'll be happy to try and replicate your workflow and see if we can get the export process to work from Blender.

The .__x formats are simply a Vizard binary format. They're entirely equivalent to the csf, caf, and cmf you're expecting and you definitely should use the normal suffixes and no the Vizard binary ones.

k_iwan 07-29-2006 03:40 PM

Cal3d animation...
1 Attachment(s)

I attached the zip files. This zip file contains all the textures and scripts required. Please copy the scripts under /Blender/.blender/scripts.. if i'm not mistaken, before exporting to cal3d. The current version of blender is 2.42a.

I also left a note inside the .blend file.

Thanks for looking into this.


farshizzo 07-31-2006 03:51 PM

The current release of Vizard only supports binary cal3d files. The files you exported with Blender are in xml format. Try exporting your Blender model into the binary cal3d format.

I just added support for xml cal3d files in Vizard, and your test file loads fine now. However, the animations don't work. Have you actually implemented the animations, or are they just placeholders for now?

k_iwan 07-31-2006 11:10 PM

Mesh Loaded, with wrong texture placement, no animations...

I did export out to binary format and I was able to load into vizard3!!!
The animations are not working. Initially, the texture wasn't loaded, then I exported out again with proper image path, the UV seemed to be messed up. The animations are definitely there. So what I'm thinking is, probably there is a problem with the exporter script. I will have another test with different bone structure... hopefully we can end this chapter nicely :D


(...then Iwan hums again.. the battle of the republic....stryper version...)

farshizzo 08-01-2006 09:21 AM

To fix the UV problem simply add the following line in your cfg file, before you define the mesh file:

flip_texture = 1
I opened up your animation files with an xml viewer and the problem is the keyframes for each bone are identical. So in theory, animations should work assuming you can correctly export them with Blender.

k_iwan 08-04-2006 03:31 PM

Sigh... I'll try something out
hmm... it appear that it is not working. The content of xml appear funny too. I'll try to generate cal3d for other 3d engine such as crystal space or Irrlicht, and hopefully I'll find something more about this format...

Thanks for bringing this up to my attention...



(again, Iwan hums "Battle Hymn of the Republic"........)

k_iwan 08-08-2006 05:38 AM

I can see Animation in Vizard!!!!! CAL3D from Blender!! (messed up but it animates!)
1 Attachment(s)

A small update! I didn't know what I did, but I can see animation in VIzard3beta.
The texture didn't appear and the animation seems to be VERY VERY exagerated, as if I double the value of rotation-translation or something (bones seems to be displaced or scale up).The root bone wasn't animated at all (tail) but it appears to be animated.

Please do have a look, perhaps someone could tell me where I went wrong?
I did reset bones rotation and scale prior doing the animations.


k_iwan 08-08-2006 05:58 AM

Another update....
1 Attachment(s)
Hi again,

I just quickly checked my animations in blender and everything seems normal.
I exported out from blender in binary format.
From the previous post, the texture didn't show up, so I applied the texture by script in vizard. Also, I added some script animations and a spot light.

Please see the updated attachment. The animation is still in a messed-up condition. Any ideas or suggestions would be greatly appreciated.


k_iwan 08-13-2006 05:26 AM

Hi All,

My Vizard3 beta is expiring really fast, only 15 days remaining. Also, there's another demo I need to create in 10 days time. I won't have time to complete this armature animation in Vizard.

Please, someone who's kind enough and have more days remaining continue my legacy :P

Thanks to the team behind Vizard, keep up the good works in vizard and Thanks for listening to us!!! I'll be back doing this armature animation if our dept. agree to make a purchase of Vizard3 (currently we have 2.53).

Kind Regards,


Gladsomebeast 08-14-2006 08:57 AM

We will release another beta build before the current one runs out on Auguest 30th. No worries.

k_iwan 08-15-2006 05:18 AM


What a beautiful song to my ears!!! Thanks for doing it!!! I'm looking forward to the next build.

Kind Regards,

k_iwan 08-20-2006 08:19 PM

Cal3d version...??

Is Cal3d 0.11.0 (latest) already implemented in Vizard R3 beta1?

Kind Regards,

Gladsomebeast 08-21-2006 03:28 PM

We are using Cal3D 0.10.0

k_iwan 06-02-2007 03:58 AM

Blender 2.44!!!!
1 Attachment(s)
Hi All,

Finally, a working Cal3D exporter is in the latest Blender v2.44
I was able to create a working animation from Blender to Vizard.

Since this only applies to Latest VizardR3, perhaps someone will leave the thread here or...move it under vizard3?

Make sure the skeleton and the mesh are selected before exporting out.
a menu (with 2 options) will pop-up, in my case, I disabled them both, firstly, I have no IK in the rig, secondly, I wanted to export all the actions out in one go.

I attached the .blend file for you guys to have a look at.

Reminder: you need to have latest VizardR3 and Blender 2.44 installed in your computer. .Blend might not be compatile with older version of blender.

k_iwan 06-02-2007 04:35 AM

...Fixed demo...
1 Attachment(s)
Ok, I'm back again, Previous loaded file has a light in the scene, and that light shouldn't be there. Hence, the cubeMan appears black.

I fixed and attached it here again, just in case if you don't want to fiddle around with the script.
I disabled the lighting in the scene, because I baked the texture in blender.


All times are GMT -7. The time now is 09:28 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC