WorldViz User Forum

WorldViz User Forum (https://forum.worldviz.com/index.php)
-   Vizard (https://forum.worldviz.com/forumdisplay.php?f=17)
-   -   About external lib (https://forum.worldviz.com/showthread.php?t=5819)

haohaoxuexi1 08-11-2016 09:05 AM

About external lib
 
I am about to install external lib to Vizard.

When I opened Tool, package manager and searched numpy, it showed up there is numpy1.11.1.

However, when I pressed installed, the following showed up.

"Collecting numpy
DEPRECATION: Failed to find 'numpy' at https://pypi.binstar.org/carlkl/simple/numpy/. It is suggested to upgrade your index to support normalized names as the name in /simple/{name}.
Cannot fetch index base URL https://pypi.binstar.org/carlkl/simple/
Could not find any downloads that satisfy the requirement numpy
No distributions at all found for numpy"

Is there any solution for this?

haohaoxuexi1 08-11-2016 10:15 AM

and there is one more question.

When I try to install numpy in Cmd command (right beside the search word)

it came out "UnicodeDecodeError: 'ascii' codec can't decode byte 0xd3 in position 9: ordinal not in range(128)"

I know the problem is "ascii" and "utf-8" code problem.

Is there a general way to solve it?

Jeff 08-12-2016 01:11 AM

There are official numpy 32 and 64 bit binaries on the PyPi site. You can download the compatible .whl installer for your platform (numpy-1.11.1-cp27-none-win32.whl or numpy-1.11.1-cp27-none-win_amd64.whl) and drag/drop into the Vizard 5 editor to install.

https://pypi.python.org/pypi/numpy/

The package manager will be updated in the next Vizard release to find the numpy installers here.

haohaoxuexi1 08-12-2016 08:12 AM

Quote:

Originally Posted by Jeff (Post 18662)
There are official numpy 32 and 64 bit binaries on the PyPi site. You can download the compatible .whl installer for your platform (numpy-1.11.1-cp27-none-win32.whl or numpy-1.11.1-cp27-none-win_amd64.whl) and drag/drop into the Vizard 5 editor to install.

https://pypi.python.org/pypi/numpy/

The package manager will be updated in the next Vizard release to find the numpy installers here.

it works, thanks for that

haohaoxuexi1 01-20-2017 10:35 AM

Quote:

Originally Posted by Jeff (Post 18662)
There are official numpy 32 and 64 bit binaries on the PyPi site. You can download the compatible .whl installer for your platform (numpy-1.11.1-cp27-none-win32.whl or numpy-1.11.1-cp27-none-win_amd64.whl) and drag/drop into the Vizard 5 editor to install.

https://pypi.python.org/pypi/numpy/

The package manager will be updated in the next Vizard release to find the numpy installers here.

i install pyqtgraph meet the same problem, is there any solution?

haohaoxuexi1 01-20-2017 01:51 PM

Quote:

Originally Posted by Jeff (Post 18662)
There are official numpy 32 and 64 bit binaries on the PyPi site. You can download the compatible .whl installer for your platform (numpy-1.11.1-cp27-none-win32.whl or numpy-1.11.1-cp27-none-win_amd64.whl) and drag/drop into the Vizard 5 editor to install.

https://pypi.python.org/pypi/numpy/

The package manager will be updated in the next Vizard release to find the numpy installers here.


this is the error comes out "UnicodeDecodeError: 'ascii' codec can't decode byte 0xd3 in position 7: ordinal not in range(128)"


All times are GMT -7. The time now is 06:05 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC