WorldViz User Forum

WorldViz User Forum (
-   Vizard (
-   -   InertiaCube2 problems (

marcoleon 08-01-2005 03:06 AM

InertiaCube2 problems

I just got an Intersense InertiaCube2 for use with Vizard, and as soon as I installed the Intersense software, I got it to work with the scaffold example, but when I restarted the computer it stopped working, even if I restarted again. Here is the error message:

ISENSE.DLL: Faile to create Shared Memory Interface to IServer. Please re-install software.

I reinstalled the software and that didn't change anything. The output is as follows:

Loading File: tut_ground.wrl
** ERROR: Failed to connect to intersense
InterSense Library ver. 3.80
Copyright 1998-2003 InterSense Inc.
Tel: 781-270-0090

Detected InterSense Server
intersense.dls Intersense Driver v2.0

Any advice will be greatly appreciated. Thank you,


mspusch 08-01-2005 03:38 PM


The Intersense products come with an installation CD that typically installs the Intersense server application. If configured correctly, the Intersense Server works directly with Vizard and you should not get such an error message. Most likely, you did not yet set up the Iserver correctly.

Vizard supports Intersense product with a native driver, therefore the Iserver software is not needed for Vizard to support the InertiaCube.

You now have two options to get your system working:

A) uninstall the Intersense server application and the Intersense drivers. Then Vizard will use it's built-in driver and will work.

B) configure the Intersense Server application correctly, so it recognizes and connects to the IC2.

Have fun!

The WorldViz Team

marcoleon 08-02-2005 05:11 PM

When I did the first option, run Vizard without Intersense software running, it worked for a while, and then, after working a few minutes earlier, I ran it again and it didn't work. This is the error message:

************************************************** ****************************
* VIZARD 2.51c *
* *
************************************************** ****************************

Loading File: tut_ground.wrl
** ERROR: Failed to connect to intersense
InterSense Library ver. 3.80
Copyright 1998-2003 InterSense Inc.
Tel: 781-270-0090

Looking for InterSense tracking device number 1.
Please wait
InterSense tracker not present
intersense.dls Intersense Driver v2.0

farshizzo 08-03-2005 08:37 AM


Have you tried specifying which port the intersense is connected to? Before you add the intersense sensor in your script trying the following:

isense = viz.add('intersense.dls')

This will tell the sensor to only look on port 1 for the intersense. Change the value to whatever port you have the intersense on.

marcoleon 08-03-2005 09:25 AM

I just tried it and it doesn't change anything... I've checked the connection, the power supply, everything seems to be connected properly.

mspusch 08-04-2005 10:59 AM

This seems to be a strange problem. Is the InertiaCube getting warm (slightly) when plugged in?

It was tested at WorldViz before it was shipped and it worked OK.
However, if it does not get slightly warm, it means that it does not get power and there could be something wrong with the power supply or the serial dongle.

marcoleon 08-04-2005 01:04 PM

I think it's getting warm, it's definitely warmer than let's say the table.

mspusch 08-04-2005 01:08 PM

This is good news and probably means the hardware is functional and the problem is on the software side. Do you have another PC available where you could install Vizard on and try if the InertiaCube works there? I just want to rule out the possibility that something left from the Intersense server installation is interferring with the Vizard Intersense driver.

marcoleon 08-04-2005 01:24 PM

It worked in another computer.

marcoleon 08-04-2005 02:19 PM

What could the problem be? I'm still trying to make it work on this computer. I've removed the intersense software with the add/remove programs control panel.

mspusch 08-04-2005 02:48 PM

the Intersense server application or service could still be running -
if it was running during your uninstall, it's possible that it did not uninstall correctly. it usually shows up in the lower right part of the start bar as an icon, and you can click on it and disable it there.
to see if a process is still running, check processes with ctrl-alt-del and search for iserver or similar. you can kill the process right there.

marcoleon 08-04-2005 03:36 PM

Neither the iserver or any isense applications are running in the start bar or in the processes list, as far as I can tell, but it still doesn't work. What else can I do?

tobin 08-05-2005 10:45 AM

I'd suggest you be sure you've isolated the cause of the problem. From reading this thread, I see you've had it working only a few times on your target computer while mostly it does not. Is it rock solid on the alternate computer (i.e., it has connected several times and never failed)?

If yes, then it's definitely a software issue. Can you tell us what version of the Intersense software you're running?

Also, if you haven't already done so, please try running Intersense's ISDemo application. This is a very reliable test program that supports all Intersense hardware and is an excellent gauge as to whether your system is working or not. You can run this directly off the CD without installing, but I'd encourage you do reinstall the Intersense software as ISServer is in fact a very useful helper app.

ISDemo should connect and find your cube immediately. If that works reliably on your target computer, then we'll know the problem is islolated to Vizard.

One other thing you might try in the next troubleshooting round is to disconnect any USB devices you have connected to your machine (include USB mice and keyboards). Intersense's autodetect function has been known to unreliably trip up when such devices are on the USB bus.

Thanks and sorry you've had to waste so much time on this troubleshooting.

marcoleon 08-05-2005 04:40 PM

The ISDemo didn't find the InertiaCube2. The first time, when I installed the Intersense software version 3.5802, it recognized it.

marcoleon 08-05-2005 04:41 PM

Oh, and there are no USB devices connected.

tobin 08-08-2005 10:08 AM

Does the cube work rock solid on the alternate machine?

Could you please email with a phone number and good times to try reaching you and we'll see if we can't get this problem solved.

Gladsomebeast 08-08-2005 11:13 AM

1 Attachment(s)

Because of the instalation of Measurand software, Microsoft ActiveSync is bocking the COM port. To stop ActiveSync from blocking the COM port open ActiveSync and select File->Connection Settings. From this uncheck the "Allow serial cable or infrared connection to this COM port:" box.

This should clear the COM port for use by Intersense.

Paul E

All times are GMT -7. The time now is 09:25 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Copyright 2002-2018 WorldViz LLC