PDA

View Full Version : Export MotionBuilder to Vizard


starlingstm
06-14-2011, 02:42 PM
I have issues with tracking in vizard;I have gone through avaiable demos. I'm getting an error message concerning the module stating. ImportError: No module named (xxxx) or a No Attribute error; I'm using Ascension Motionstar. I'm not sure what the module is?

Jeff
06-24-2011, 11:40 AM
Are you using Live Characters and Motionbuilder to map MotionStar data to an avatar in Vizard or are you trying to get MotionStar data into Vizard using the Ascension plug-in? Can you post an example of the code you are using?

starlingstm
06-27-2011, 03:13 PM
I'm trying to pull the information from MotionStar into Vizard with the Ascension plug-in. I'm running a for-loop to grab the sensors and assign to a sphere, then trying another for-loop to grab the bones and link to the avatar to a sensor. Here is a my code

import vizconfig
import vizshape
import time


viz.go()

female = viz.add('vcc_female.cfg')

ascension = viz.add('ascension.dle')
sensors = ascension.addMotionStar('10.32.16.31')


# Array of color to assign to sensors
colors = [viz.RED,viz.BLUE,viz.YELLOW,viz.GREEN,viz.PURPLE,v iz.GRAY,viz.WHITE,viz.ORANGE,viz.YELLOW,viz.GRAY]
bones = ['Bip01 Head','Bip01 Spine1', 'Bip01 L Forearm', 'Bip01 R Forearm', 'Bip01 L Hand', 'Bip01 R Hand','Bip01 L Thigh', 'Bip01 R Thigh','Bip01 L Foot','Bip01 R Foot']

# Loop to grab each sensor from MotionStar

for s in sensors:
# i=sensors.getBirdNumber()
# print i
model = vizshape.addSphere(0.05, color=colors[s.getBirdNumber()])
# model = vizshape.addSphere(0.05)
viz.link(s,model)
# print s.getBirdNumber()
#for s in sensors: prints

for b in bones:
head = female.getBone(b)


viz.link(s,head)

import vizcam
vizcam.PivotNavigate(center=[0,1,0],distance=1)

PLEASE HELP!!

Jeff
06-28-2011, 01:44 PM
In a previous thread I asked if the following code works for you but I did not get a response. Do you get an error when running this after you replace the IP address with your MotionStar server IP?
import viz
viz.go()

ascension = viz.add('ascension.dle')
sensors = ascension.addMotionStar('10.32.16.31')

for s in sensors:
model = vizshape.addCube(0.1)
viz.link(s,model)

starlingstm
06-29-2011, 12:25 PM
I do not get an error when I run the code you posted, and I'm trying to build onto by attaching the sensor to an avatar directly from MotionStar to Vizard. Thanks so much assisting me.:)

Jeff
06-29-2011, 04:28 PM
Our workflow for animating a character using mocap data includes Motionbuilder and Live Characters. Motionbuilder handles the inverse kinematics and calculates where all the bones should be. If you try to directly map tracking data to the avatar's bones in Vizard it will not look correct.

starlingstm
06-30-2011, 01:56 PM
That explains why my avatar's body is all over the place. I thought it was scaling and euler issues. Thanks.