PDA

View Full Version : How to use vicon plug-in?


llqqff
05-04-2009, 10:30 AM
I tried to use the HMD to track the marker from the vicon motion capture system. But it always says: Failed to create Socket, although I addressed the port of the vicon server.

And I remember you said: the plugin allows to add as many sensors as there are bodies. What do you mean by body?

farshizzo
05-05-2009, 01:58 PM
Are you using the vicon.dls plugin or the vicon.dle plugin? Also, are you sure the Vicon server has real-time streaming enabled?

llqqff
05-05-2009, 08:21 PM
I am using the vicon.dls and I am sure that the real-time streaming is enabled.
I am using the simple.py that you provide for vicon hardware.
I just don't know where is the problem. Is there any specific configuration in Vizard or Vicon?
Do you have any steps that I can follow to do it?

llqqff
05-06-2009, 08:42 PM
I set the real time server acitive in Vicon
And there are three connections on my computer with vicon:
connection to Internet: IP address: 129.59.70.136
connection to vicon ultranet: IP address: 192.168.10.1
connection to local area switch: IP address: 192.168.1.100

I tried all the three IP address, but when I run the simple.py in vizard, it still can not create the socket.
Can you see where is the problem? Thanks a lot!

farshizzo
05-07-2009, 12:30 PM
Try using the newer version of the Vicon plugin (vicon.dle). The documentation has sample code showing how to use the plugin. Do you know what port the Vicon is streaming data over?

llqqff
05-07-2009, 12:53 PM
Sorry, I don't know the port. I tried both 800 and 803 when I used vicon.dls.
But I will try the vicon.dle to see how it works.

llqqff
05-07-2009, 01:55 PM
Hi Farshizzo,

I tried the vicon.dle, but it still can not work, the code I am using is:

vicon = viz.add('vicon.dle',0,'192.168.1.100')
body = vicon.getBody(0)
marker = vicon.getMarker(0)

print body.getName()
print marker.getName()

The error message:
** Vicon Error: Server connection timed out (0)
** ERROR: Failed to connect to Vicon server at 192.168.1.100:803
** ERROR: Failed to create extension: vicon.dle
Traceback (most recent call last):
File "<string>", line 11, in ?
File "test1.py", line 5, in ?
body = vicon.getBody(0)
AttributeError: 'VizExtension' object has no attribute 'getBody'

Do you know what is the problem?

farshizzo
05-07-2009, 02:57 PM
You might be connecting on the wrong port. The default port should be 800. If you are positive that you are connecting over the correct port, then you might have a firewall that is blocking the connection request. Check if the server is running a firewall and try disabling it to see if Vizard can connect.

Moh200jo
09-08-2009, 04:30 AM
Once I done the connection, how can I animate the avatar in Vizard through Vicon?

farshizzo
09-09-2009, 01:33 PM
See my reply in this thread (http://forum.worldviz.com/showthread.php?p=8655). In the future, please post your question once in a new thread.