View Full Version : PPT vs. VPRN - Position Tracking not Working

02-26-2007, 03:26 PM

I'm trying to run some new scripts & some of the demos, and getting a recurring issue. I have PPT up and running, and specify that I want to use it on port 4 (code later), but it looks like VPRN is still being loaded, and the port isn't working.

vizppt.dls WorldViz PPT v2.0
vrpn_open_commport: cannot open serial port: No such file or directory
vrpn_open_commport: cannot open serial port: No such file or directory
** ERROR: Failed to connect to PPT

if viz.get(viz.TRACKER):
v = viz.add('intersense.dls')
pos = viz.add('vizppt.dls')
tracking = 1
tracking = 0

(the above code from the gallery demo)

I'm not sure what's going wrong. Any ideas?

02-26-2007, 03:33 PM
You will need to explicitly specify the port you want to connect to. Try the following before adding the ppt sensor:PORT_PPT = 4

02-26-2007, 03:37 PM
Still no luck -
vrpn_open_commport: cannot open serial port: No such file or directory
** ERROR: Failed to connect to PPT

One less error, but still it isn't loading position tracking.

02-26-2007, 03:38 PM
That is, with the modified code:

if viz.get(viz.TRACKER):
ori = viz.add('intersense.dls')
pos = viz.add('vizppt.dls')
tracking = 1

Thanks for the quick reply!

Edit: Changing PORT_PPT to 1 just gives

** ERROR: Failed to connect to PPT

02-26-2007, 03:41 PM
Can you make sure that the PPT is properly setup to send data over the serial port. I've attached a screenshot of the PPT options where you need to specify the serial port for the PPT to send data. It should usually be set to "COM1"

02-26-2007, 03:45 PM
Was just on that page - it was set to COM2, I set it to COM1, and the same error occurred on the other side.

02-26-2007, 03:49 PM
Also, the Talk button on PPT wouln't stay down when it is set to COM1

02-26-2007, 03:50 PM
Are you using a serial to usb converter on the receiving computer? If so, can you double check that the port is 4?

02-26-2007, 03:52 PM
If the talk button isn't staying down, then the port is invalid. Does it stay down when the port is 2?

02-26-2007, 03:55 PM
Nope, it's a real COM port on both sides, pretty sure. Originally I think that the port was 4, when that stopped working I'm not sure.

Is the error message "No such file or directory" correct for an incorrect COM port? And is there any way to test what is on which ports without rerunning scripts?

02-26-2007, 03:57 PM
Also try to set the PPT to output on COM3 or COM4.
The newer versions of the PPT computer often times output on
either COM3 or COM4.

As Farshizzo mentioned, if the TALK button does not stay down, then most likely you are trying to output on a COM-PORT that is invalid.

Just to make sure, you have your PPT computer connected over a Serial Nullmodem Cable with the rendering computer, i.e. you are trying to stream PPT data over serial?

I'm just asking this because of your mentioning of VRPN initially.

02-26-2007, 04:02 PM
COM3 and COM1 both don't work, as far as the Talk button.

I mentioned VPRN because when we set the system up (a week ago) it gave these errors with after updating to Vizard 3.0 and Bryce thought it was odd because we aren't using VPRN at all. From what I can see, a straight serial cable connects the rendering and tracking boxes.

02-26-2007, 04:06 PM
If your PPT computer was configured to output on COM4, and you did not change the physical port the Nullmodem cable is plugged in,
then most likely you should set it to COM4 again.

In almost all cases when a PPT that has previously worked does not work any more, it's because

A) someone changed some basic setting on the PPT options (like outputting on the wrong port etc.)

B) the file that is selected for a calibration file is not a valid calibration file.
you need to click on the calibrate button and select the option 'load existing calibration file' and point the PPT at the most recent calibration file.

alternatively you can re-calibrate and create a new file. calibration should take you about 2min.

If you have re-calibrated and click tracking and the tracking button stays in, then you should see a solid white line when you move the marker around.

if that is the case, then connect your serial port 4 (COM4) over to the Vizard (rendering) computer with the Nullmodem cable,

then look up on the Rendering computer which COM port it connects to there on the rendering computer, and THEN specify with PORT_PPT = 5 (or whatever COM port on the rendering computer the NULLMODEM cable connects to) in the VIzard script.

02-26-2007, 04:11 PM
I've just tried loading the two most recent calibration files. How do I find out from the rendering computer which com port will connect to the PPT? (Although, after trying all of them, I'm a little discouraged)

02-26-2007, 04:20 PM
Anyway, I'm done for the day, I'll try to get it working tomorrow afternoon for a demo.

02-26-2007, 04:29 PM
on the rendering computer, there are typically three options for the COM port that the PPT is connected to:

A) Most likely in you case: it's connected over a PCI to serial card. To find out which COM port this is most likely, go under Start-control panel, click on system, select 'hardware' tab, click on 'device manager' and look which COM ports the PCI-Serial adapter connects to.

B) If your computer has a native serial port, and that was used, then it's probably COM1 or COM2 (these are typically the native serial ports)

C) if a USB to serial adapter (dongle) was used for connecting your rendering computer, thatn follow the desctiption of A) and figure our which COM port the USB/Serial dongle connects to.

Once you know (or suspect to know) the port that the PPT data comes in thru then run the Vizard script and see if this helps.

NOTE: the COM-port settings of the PPT computer have NOTHING to do with the COM-port settings on the Rendering computer (with Vizard).
Once the PPT works, do NOT change any of the COM-port settings around, as the physical COM-ports on the PPT do not change.

Once the PPT runs, it runs reliably and typically literally for years (if you don't move the cameras), so for normal laboratory use, it's not required to change anything on the PPT side other than how many points are tracked.

Hope that helps. sorry for the confusion, and have a good evening.

02-26-2007, 05:17 PM
I think I remember your PPT machine using COM 2. Your Vizard scripts use COM 5 or 6.

Try these settings on one of the demo scripts and see if it works.

The errors we were getting while I was there were unrelated to this issue. That problem has been solved. You should only be using Vizard 3.0.

- Bryce

02-27-2007, 02:56 PM
The two calibration files I have send from Port 4. I've tried all combinations of 4 sending, and 1-6 receiving, and no luck at all. 1 & 3 give "could not connect to PPT" errors, and the rest give no file/directory errors.

02-27-2007, 02:58 PM
The device manager lists ports as:

Communications Port (COM1)
NetMos PCI Serial Port (COM3)
NetMos PCI Serial Port (COM4)
NetMos Unusable Parallel Port (LPT3)

02-27-2007, 03:02 PM
I think this issue might be more easily solved if I can support you over the phone. call me at 805-966-0786 ext 207 when you get a chance.


02-27-2007, 03:11 PM
alternately you can call me toll free at 888-841-3416 ext 207.

02-27-2007, 03:19 PM
Finally, it's working. Needed to send on Port 2 and receive on Port 3. Never would've guessed. Thanks for all the help.