WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 09-14-2017, 06:05 AM
rdkirkden rdkirkden is offline
Member
 
Join Date: May 2017
Posts: 14
HMD view jumps

Hi,

When I run my current Vizard program (in Vizard 5.7) and view using an HMD (Oculus Rift DK2 running SDK 1.16), the view occasionally jumps to the side and back again. Itís a flicker really, over in a second or less, but itís quite jarring. This seems to happen at random intervals, often a few minutes or sometimes tens of minutes apart, and it happens regardless of whether or not the avatar is moving. It does not happen, as far as I can tell, on the 2D view I have running concurrently on the monitor, or in a separate program I wrote for 3D glasses that doesnít use an HMD. Iíve used Vizconnect to set up all the interactions between HMD, tracker, game controller, avatar and transport, but Vizconnect doesnít seem to be the problem because the jumping also occurs in an older Vizard program that I wrote without using Vizconnect.

To be honest, itís difficult to make comparisons between programs because the intervals at which jumps occur are so variable. It might be that although jumping occurs in all my HMD programs, the frequency differs between them. A case in point is when using the HMD to view the Oculus Ďcityscapeí home site without running a Vizard program: in this case I have seen jumping happen once, but it seems very much less frequent than when running my current Vizard program.

I wonder if the jumping could be a hardware issue. My graphics card (an NVIDIA GTX970) meets the minimum system requirement for the Oculus Rift DK2 and Iím using a non-shared USB 3.0 port for the positional tracker. However, my processor is a bit slower than the minimum system requirement: itís an Intel Xeon E5520 (4 cores, 8 threads, 2.26 GHz), whereas the minimum requirement specifies an Intel Core i5-4590 (4 cores, 4 threads, 3.3 GHz) (https://product-guides.oculus.com/en...on/dk2/latest/).

Any advice would be much appreciated.

Richard.
Reply With Quote
  #2  
Old 09-14-2017, 09:31 AM
rdkirkden rdkirkden is offline
Member
 
Join Date: May 2017
Posts: 14
Actually, I was wrong about one thing. When the view jumps on the HMD, it does also jump on the 2D display that shows concurrently on the monitor. The jump is less noticeable on the 2D display, but it is there. I teamed up with somebody else so we could monitor both views at once.
Reply With Quote
  #3  
Old 09-14-2017, 09:09 PM
Jeff Jeff is offline
WorldViz Team Member
 
Join Date: Aug 2008
Posts: 2,307
You could try testing with a simple Vizard script like oculusExample.py (File > Quick Open > Type: oculusExample). That should run at a stable 75 fps in the DK2. Press F4 to see the framerate. If the framerate is stable and you still notice jumps it's likely not a rendering issue. It could be due to drivers, hardware, or the tracking.
Reply With Quote
  #4  
Old 10-04-2017, 07:17 AM
rdkirkden rdkirkden is offline
Member
 
Join Date: May 2017
Posts: 14
Hi Jeff,

Thanks for your reply. The frame rate reading fluctuates continuously between about 74 and 76 fps, changing almost too fast to see Ė I think this probably counts as stable, doesnít it? When the HMD image jumps, this has no effect on the frame rate reading.

I donít think the graphics card driver is likely to be the problem, as I updated this quite recently. The Oculus SDK, which includes drivers, is version 1.16 and this was also installed quite recently. I wonder if updating to version 1.18 would make any difference?

As regards the tracker, I have it plugged into a USB 3.0 port on a PCIe USB 3.0 card that is connected to the motherboard. As far as I can tell, this PCIe slot isnít sharing bandwidth with anything else. At any rate, the Oculus Configuration Utility showed that the tracker was not dropping frames when I was running Oculus SDK 0.8 (this utility no longer seems to be available in SDK 1.16).

As far as the PC hardware is concerned, I suppose it could either be the processor or the graphics card, as the processor falls short of the minimum system requirements and the graphics card only just meets them. Do you have a view as to which is the more likely candidate?
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
view in view mms Vizard 6 07-19-2017 02:37 AM
animation path problem - coordinates not resetting jelly Vizard 7 04-26-2016 10:45 AM
View nlfrnassimi Vizard 0 03-17-2009 02:01 AM
View nlfrnassimi Vizard 4 03-12-2009 05:25 AM
problem with stereo mode shivanangel Vizard 3 10-17-2006 09:58 AM


All times are GMT -7. The time now is 04:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2014 WorldViz LLC