WorldViz User Forum  

Go Back   WorldViz User Forum > Vizard

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 04-23-2018, 06:55 AM
seowen1 seowen1 is offline
Member
 
Join Date: May 2017
Posts: 9
Exclamation Vizconnect selection not working in EXE

Hi there,

I have a project where I would like to be able to select the vizconnect configuration file and run the correct platform based on user input. For instance, if the user is running with Oculus, they would select "OCULUS" from a dropdown menu and it would configure the trackers, displays etc.

Here's the code I have:

Code:
#Choose a Vizconnect and GO
platform = ['DESKTOP', 'VIVE', 'OCULUS']
choice = viz.choose("Choose a vizconnect: ", platform)
vizChoices = ['vizconnect_config.py','vizconnect_config_vive.py', 'vizconnect_config_oculus.py']
vizconnect.go(vizChoices[choice])
viz.go()
This works fine when running on the script through testing... but as soon as I try to publish this it breaks for the platforms that it was not run on to test. For instance, if I publish and run selecting "DESKTOP" mode, the resulting EXE will only work for desktop mode.

My first thought was that I need to make sure the export settings are pulling in the other vizconnect_config files that weren't being used. So I did that. Still nothing.

My next thought was that it wasn't importing the proper dependencies that those vizconfig files relied on (i.e. import steamvr, import oculus), so I added those to the export. Still nothing.

I'm a bit lost here. Any help on how to achieve this?
Reply With Quote
  #2  
Old 04-23-2018, 08:02 AM
seowen1 seowen1 is offline
Member
 
Join Date: May 2017
Posts: 9
Solved.

I needed to import the steamvr.dle and the oculus.dle from the Vizard program files folder.
Reply With Quote
Reply

Tags
exe, oculus, publish, vive, vizconnect

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to set the position of view with vizconnect apenngrace Vizard 1 08-04-2015 12:01 PM
Switching between input devices setup in vizconnect and not using vizconnect JB_HP_Viz Vizard 1 01-20-2015 06:19 AM
cannot get eyeheight() working with vizconnect johnallen Vizard 2 11-24-2014 04:48 AM
Vizconnect SpaceGrip problem JB_HP_Viz Vizard 3 06-17-2014 03:03 AM
Vizconnect Save As Dialog Jeff Vizard 0 05-01-2014 09:45 AM


All times are GMT -7. The time now is 08:15 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2002-2014 WorldViz LLC