PDA

View Full Version : The error window that couldn't


FlyingWren
11-26-2003, 02:57 PM
Okay, here's the deal:

I have a Vizard script that works perfectly in "testing" mode, ie, when it is just issued a viz.go()

When I take it out of "testing" mode to try it with the headmount, the script doesn't run -- the only script difference is that instead of viz.go(), I issue this:


viz.go(viz.STEREO)
viz.cursor(viz.STOP)
posTracker = viz.addsensor('vizppt')
oriTracker = viz.addsensor('intersense')
viz.tracker()
posTracker.reset()
oriTracker.reset()


...When I run this, a window whose title is "Error" pops up on the screen. I can't see its contents because it's always covered by the "Loading..." window. See attached picture.

I've tried get the "Error" window out from undearneath the "Loading..." window in a variety of ways to see the error message, but to no avail; it's always covered.

Our other scripts work just fine with the above tracking code. We are using vizard 2.12, by the way.

mspusch
11-27-2003, 12:11 AM
Hi Wren,

Thanks for the detailed description of this error.

A) For moving the error window, you should see a window called 'Error' in the windows bar. Left-click on it and select 'move'. Your cursor gets automatically placed over the error message window and you can now left-click on it and move it.

B) We did some testing and think your error message might be related to the ppt driver and the com port. We could only replicate it on xp systems and with an old version of the vizppt driver. Please make sure your vizppt.dls is the most recent one that comes with the Vizard 2.12 install (vizppt.dls built 10/24/2003).

C) In case Vizard did not overrite the old driver when installing 2.12, rename your Vizard20 directory and install Vizard 2.12 new.
You can then either work with the new installation or switch back to the old one, but move the latest version of the vizppt.dls into the Vizard20/plug-ins folder.

Hope that helps.

Matthias

FlyingWren
12-02-2003, 09:23 AM
I didn't think to try moving the error window that way-- when I do, it reveals the following text:

Couldn't get handle (COM)
(with an 'OK' button below)

I checked the vizppt.dls version in our Vizard20 directory, and it is indeed the 10/24/03 build. If you would like me to give reinstalling a try to get rid of any suspicion about out-of-date files, I can do that :)

(The fact that it our other scripts run fine with the tracker on might be some sort of clue here, I don't know...)