PDA

View Full Version : eMagin stereo


DAZ
12-17-2008, 11:37 AM
I work for a virtual reality company, and we’ve been having trouble recently getting stereo working on the newer nVidia graphics cards, as nVidia has not been supporting this type of stereo.

Our main goal is to get the eMagin Z800 working in stereo (frame sequential, a.k.a. alternating frame) on a newer graphics nVidia graphics card (we’re aiming for specs like the Quadro FX 3700) that supports CUDA (the program we are making will be using CUDA, nVidia’s language to do processing on their graphics cards) (so probably a GeForce or Quadro FX card). We will be using Dual View (monitor runs 1024 X 768 or else 1280 x 1024 and eMagins run their normal 800 x 600). We are aiming to do all this on Windows XP. However, if we can only get this to work in Vista, this is a possibility.

We did some research roughly 3 months back on the subject with no real answer. We tried using eMagin’s tools that use their own software for 3d, but we found 2 problems: 1) frame rates below a certain number swapped which image is displayed in which eye and 2) when starting up, half the time the eyes were swapped and the other half the time they were fine (and we could not find a way to correct the former). As our frame rates will be inconsistent, we cannot rely on the first, and the second is just unusable. It’s possible we missed something or incorrectly used the tool, but that’s what we found. We tried this on a Dell PC with an nVidia Quadro FX 3700.

Our internal deadline for trying to find out if we can get eMagins working for us is 12/23/08. However, this will not cause significant impact until 1/12/09.

This is not a plugin for Vizard, but we've heard that WorldViz may have found a way of doing this and are interested. Any information you can provide would be greatly appreciated.

farshizzo
12-17-2008, 12:49 PM
If you are targeting nVidia Quadro cards, then you should use quad buffered stereo. Quad buffering maintains correct swapping, regardless of framerate. To try it out in Vizard, simply use the viz.QUAD_BUFFER with viz.go():viz.go(viz.QUAD_BUFFER)Make sure you enable stereo in the 3D settings tab of the nVidia control panel.

reedev
01-23-2009, 05:09 AM
Hi,

Are you sure this is working with modern gfx cards? It was my understanding that you need an older Quadro card. Personally I use a Quadro FX3450 which works nicely.

regards
Raymond

farshizzo
01-24-2009, 11:55 AM
Vizard's quad buffering feature should work fine with modern quadro cards. Is there a particular model you have had problems with?

reedev
01-25-2009, 01:33 AM
Hi,
No, not particularly. It is what I've heard from a friend who had this experience. Although not with vizard, but doesn't change it. I didn't even try a modern card since these are pretty expensive...

thanks for your note
Raymond